My notifications are not working right

Discussion in 'iPhone' started by rei12345, Mar 16, 2013.

  1. rei12345 macrumors newbie

    Joined:
    Dec 16, 2012
    #1
    So there are 2 problems about notifications on my iphone

    1. the notification badges wont show up until i open the apps. I told this to the apple guy but he said it was a bug. But my family and friends doesn't have this problem. I have all the apps ON on my notification center. I researched this but it didnt help me alot.

    2. Whenever my phone is asleep, the notification shows in the lock screen. But when I open my phone, the app that has a notification opens directly to it. Its really annoying. When I researched this, i found out that this problem is rare.

    My iphone is not jailbroken. I really need help, if you have any solutions please say anything you know.
     
  2. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #2
    1. do you still get banner/alerts notifications? if yes, under notifications, do you have "badge app icon" on?

    2. as far as i'm aware, when you first the see notification on your lock screen and you just unlock it, it'll take you straight to the app. however, if you press the sleep button to put your phone to sleep and then unlock your phone, it should take you to the home screen
     
  3. Kurios2 macrumors regular

    Kurios2

    Joined:
    Sep 22, 2012
    #3
    darricksailo is right and that's a good feature of the iphone. Apparently, yours is off. Sometimes I get so many that I turn the badge icon off.
     
  4. rei12345 thread starter macrumors newbie

    Joined:
    Dec 16, 2012
    #4
    Sorry for the late reply.

    1. Yes I get banners and alerts and yes i have made all my apps on for badges.

    2. Recently, im not having this problem. But thanks for the information.
     
  5. rei12345 thread starter macrumors newbie

    Joined:
    Dec 16, 2012
    #5

    What should I do about the notification badge???
    I made all of my apps on for the badges but its not working. I have alot of apps in my iphone, that may be the problem but maybe its not. I need HELLPP :(
     
  6. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #6
    Have you tried restarting your phone by holding the power and home button until the apple logo shows up?

    Are you jailbroken?
     
  7. rei12345 thread starter macrumors newbie

    Joined:
    Dec 16, 2012

Share This Page