My ol' MBP is clickless!

Discussion in 'MacBook Pro' started by xyzzyva, Dec 31, 2008.

  1. xyzzyva macrumors newbie

    Joined:
    Dec 30, 2008
    #1
    Since yesterday, I've been unable to click with my first-gen MacBook Pro. The system doesn't freeze or anything, and the trackpad itself and keyboard still work. I can't pull up the Dock. When I plug in a USB mouse, the same thing occurs: I can move the cursor, but not left-click (I can right-click with the mouse).

    I searched everywhere on the net, and only found one mention of a similar issue, here.

    Since I'm no longer under warranty, I opened it up to see if a cable had come loose or anything, to no avail. It's got me at my wit's end... it's almost worse that I'm able to move the pointer, since I can't click anything! The local Genius Bar is full up for 4 more days (lousy holiday season!! ;)), does anyone have any suggestions in the meantime?
     
  2. dukebound85 macrumors P6

    dukebound85

    Joined:
    Jul 17, 2005
    Location:
    5045 feet above sea level
  3. xyzzyva thread starter macrumors newbie

    Joined:
    Dec 30, 2008
    #3
    Uh, yes. I also tried resetting the SMC and PRAM, repairing disk permissions, and booting into safe mode. I even tried booting into a live CD version of Ubuntu, to rule out a hardware issue, but it ejected the CD on boot.
     
  4. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #4
    It sounds like the button is stuck in. That would explain why the external mouse won't click (it already is) and the CD is being ejected because holding the button will force an eject.
     

Share This Page