My only gripe

Discussion in 'Apple TV and Home Theater' started by nando2323, Mar 10, 2008.

  1. nando2323 macrumors 6502a

    Joined:
    Aug 15, 2007
    #1
    Is that my :apple:TV never reconnects to iTunes automatically after the computer wakes from sleep. I always have to quit iTunes and restart it every single time. I am at the point that I just want to create a script or Automator flow that will do this for me. Anyone else experiencing this behavior? Besides that it works great.
     
  2. uva25 macrumors regular

    Joined:
    Feb 2, 2008
    #2
    Don't put the computer to sleep.
     
  3. GoCubsGo macrumors Nehalem

    GoCubsGo

    Joined:
    Feb 19, 2005
    #3
    Well that's silly! Some...most of us DO put our computers to sleep. I'm interested in a fix too as I do not intend to have my computer be awake 24/7.
     
  4. uva25 macrumors regular

    Joined:
    Feb 2, 2008
    #4
    Why do you put it to sleep? If i may ask a "silly" question.
     
  5. err404 macrumors 68020

    Joined:
    Mar 4, 2007
    #5
    I agree that this is a valid concern. What is a users main machine is a laptop? The main reason the Apple TV syncs content in the first place, as opposed to just exclusively streaming, is precisely that the host should not need to be available 100% of the time.
    I just got a Mac mini for hosting to the Apple TV (among other things) and I would like to have an automatic weekday sleep/wake schedule. The machine is idle for over 100 predictable hours a week. it seems 'silly' to have it awake all of that time. ;)
     
  6. BaldiMac macrumors 604

    BaldiMac

    Joined:
    Jan 24, 2008
    #6
    I have a MacBook and never have had problems connecting to the AppleTV after awaking from sleep.
     
  7. nando2323 thread starter macrumors 6502a

    Joined:
    Aug 15, 2007
    #7
    Because I don't own National Grid would be my answer.
     
  8. KershMan macrumors 6502

    Joined:
    Feb 10, 2003
    Location:
    VA, USA
    #8
    You shouldn't have to close iTunes but go to Computers (used to be Sources) and reconnect from the AppleTV.
     
  9. megfilmworks macrumors 68020

    megfilmworks

    Joined:
    Jul 1, 2007
    Location:
    Sherman Oaks
    #9
    That is a strange problem. I haven't seen that on my Macbook Pro.
     
  10. mchalebk macrumors 6502a

    Joined:
    Feb 4, 2008
    #10
    "Why do you put it to sleep? If i may ask a "silly" question."

    There are many good reasons to put a computer to sleep:

    1. Electricity. I have an old PowerMac with two monitors. I am sure that the amount of electricity used is not nominal.
    2. Noise. My PowerMac is a Quicksilver and is loud. It doesn't make any noise when it's asleep.
    3. Reliability. There was a time when it was considered better to leave a computer on all the time, but that's no longer the case. Putting a computer to sleep when you're not using it will allow it to last longer.

    There are probably some more reasons that I can't think of off the top of my head.

    I have not had the problem with AppleTV having to reconnect after waking, but thought it was important to point out that there are good reasons to put a computer to sleep. Furthermore, sleep is a function available on Macs that you ought to be able to use without adverse side effects. If someone posts that they're having a problem when they do something, it's really not all that useful to say "don't do that".
     
  11. kagharaht macrumors 6502a

    Joined:
    Oct 7, 2007
    #11
    What you need to do is sleep ATV first. Then you can either sleep your desktop Mac or shut it down. As long as ATV is in sleep mode, you can do this with your Mac that host your iTunes database. Set your Mac to auto wake every morning. When you turn on ATV it will stay synched.
     
  12. nando2323 thread starter macrumors 6502a

    Joined:
    Aug 15, 2007
    #12
    Seems like this would solve my problem. But it should not work like that I think it should just reestablish the connection once the computer is awake.
     

Share This Page