My Passport External Drive Failure / Disk Utility failed

Discussion in 'OS X Mavericks (10.9)' started by supernerdjovan, Sep 10, 2015.

  1. supernerdjovan, Sep 10, 2015
    Last edited: Sep 10, 2015

    supernerdjovan macrumors newbie

    Joined:
    Sep 10, 2015
    #1
    Hello,

    I did some searching in this forum and others, but couldn't find an answer to my specific issue. I am having trouble with my external hard drive. It mounts and the files show up, but I get the spinning beach ball when I try to interact with the files and I am unable to unmount or write to the disk.

    After I ran Verify Disk, it said the disk needed to be repaired. I tried to repair it, I get a "Disk Utility cannot unmount disk" error. I tried copying the disk to a new volume through Disk Utility, and that didn't work either. Time Machine also does not work. When I try to copy the files by simply dragging and dropping in Finder, I get an error telling me that either a file is in use, or ".DS_Store" is in use.

    It's clear the disk is corrupted, but it still mounts to my computer so that's a good sign, I hope? What are my options here? How do I get the files off the disk? This is really driving me nuts. If there are options that don't involve spending lots of money, that would be most appreciated!

    Thanks!
     
  2. ricede macrumors regular

    ricede

    Joined:
    Aug 16, 2010
    Location:
    Inside
    #2

Share This Page