my powerbook doesnt recognize my canon 350D

Discussion in 'Digital Photography' started by markrimmer, Jul 23, 2006.

  1. markrimmer macrumors newbie

    Jul 23, 2006
    i have a powerbook G4 running OSX 10.3.9. i just got a Canon 350D, when i plug it in it doesn't recognise it. nothing happens. it works fine with my wife's new macbook, which has Tiger. i can't find a driver to download. can anyone help?
  2. cookie1105 macrumors 6502

    Mar 27, 2006
    London, UK
  3. sjl macrumors 6502


    Sep 15, 2004
    Melbourne, Australia
    Yeah, OS X seems to be a little flaky when it comes to Canon DSLRs; I have the same problem with my 20D (although I haven't tried connecting the camera direct to my Powerbook running Tiger, I have tried it with my mini running panther ... exact same problem.)

    My suggestion: get a USB or firewire card reader. Shouldn't cost you more than twenty to thirty dollars, and it works no matter what OS you're running on your Mac.
  4. T10HJS macrumors member

    Sep 18, 2008
    Milton Keynes
    I have the same issue with my Eos 350d :(
    Is there no work around? you thought they would of resolved this issue by now as the last post on this thread was in 2006..... :confused:
  5. AlaskaMoose macrumors 65816

    Apr 26, 2008
    I haven't had such problems with my first generation iMac running under OS 10.3 and now 10.5.6, except for when connecting any brand's point & shoot camera. I have a XT, and a 40D. I do update the OS regularly, so maybe that makes a difference.
  6. jaseone macrumors 65816


    Nov 7, 2004
    Houston, USA
    Does your camera show up as an Image Capture device at all and just not mount? This is how the new Nikon D90's behave as for some reason Nikon decided to leave that USB mode out.

    Regardless it is always best to use a card reader as it is generally faster plus doesn't drain your camera's battery.
  7. T10HJS macrumors member

    Sep 18, 2008
    Milton Keynes
    It just refuses to acknowledge that any device has been attached, i forgot all about adobe bridge, used that and it instantly spotted my 350D and the pics came off nice and fast :)
    Just was expecting it to pop up in the left on Finder.
    Think i will be buying me a card reader.

  8. basstroomer macrumors newbie

    Mar 5, 2009

    I had the same problem, but solved it for me.

    My Canon 40D worked once before on my new macbook pro, but now it suddenly didn't.
    I went crazy, and finally realized I bought a new (non-original) battery. I changed it for the original and it worked...straaaaange....

  9. namethisfile macrumors 65816


    Jan 17, 2008
    how about downloading canon software for panther that transfers the files from your camera? i know that nikon has xtransfer which does the same thing. and canon should have an equivalent software.

    although, os x has image capture, which could also work.

    or, a card reader could work too, as someone else suggested.
  10. leighonigar macrumors 6502a

    May 5, 2007
    Are you sure you have your camera set to mass storage and not PTP? I am not totally sure if this still matters. Worth checking the USB mode.
  11. hairymango macrumors newbie

    Jun 7, 2012

Share This Page