my powerbook is rapidly deteriorating

Discussion in 'macOS' started by choco6, Oct 12, 2007.

  1. choco6 macrumors newbie

    Joined:
    Sep 29, 2007
    #1
    for the past two days, my trusty 4-year-old powerbook g4 has turned into an almost unusable computer. these are the things that i have noticed (so far), and please keep in mind that all of these problems happened at the same time:

    1. all of the pictures i've taken and imported into iphoto in the last two months were deleted (seriously, they aren't there. i've tried looking in the original source file and i've rebuilt the library). any picture that wasn't deleted would show up as a question mark when i double clicked on it in iphoto.
    2. my ipod no longer syncs or charges with itunes. also, itunes can no longer save new songs.
    3. random word documents from the past two months have disappeared. the ones that haven't disappeared won't open, and word gives me the following message when i do try to open them: "x.doc is being used by another user. do you want to make a copy?"
    4. i can't download or save any files from the internet. i've tried on both safari and firefox.
    5. some of my desktop icons (just the icons) have turned invisible, and you can only tell that the file is there by its filename. if i click on the file once, it disappears and will only reappear when i restart the computer. again, this is only for files from the past two months.

    to be honest, i have no idea what caused these problems. although it might be hard to believe, i hardly ever have computer problems i can't fix. i'm the person that people come to with their computer problems. i bet a lot of the people on this forum are like that, so i'm sure a lot of you guys can sympathize with how frustrating this situation has been.

    do any of you know what might have happened here, and how i can fix any of these problems? it seems like my hard drive suddenly turned into read-only, but with limited access. who knows.

    thanks in advance.
     
  2. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #2
    Repaired permissions and repaired the drive?

    Though looking at some of the permission with get info might shine some light on the problem.

    Sounds like a file catalog problem or a permission problem.

    ---

    Though it might be something else goofy going on, tried a safe boot? or a new user?
     
  3. choco6 thread starter macrumors newbie

    Joined:
    Sep 29, 2007
    #3
    i did repair the permissions for the hard drive. nothing. the hard drive's permissions are also set to read & write.

    haven't tried a safe boot yet. i'll do that right now.
     
  4. choco6 thread starter macrumors newbie

    Joined:
    Sep 29, 2007
    #4
    tried safe mode. everything still acted goofy, and no insight was gained.

    although when i tried using word on a new user, everything went well. so there's hope for the least of my problems, i suppose. i just wish i could get all of my photos back.
     

Share This Page