My PowerMac won't start up

Discussion in 'PowerPC Macs' started by MrKalius, Feb 8, 2011.

  1. MrKalius, Feb 8, 2011
    Last edited: Feb 16, 2011

    MrKalius macrumors newbie

    Feb 8, 2011
    It's pritty bad. Because I'm not to sure what I'm supposed to do. Basically, I think my Mac is bust. I sat down to go on it and decided that I wanted to download some games for my G4 Mac PowerPC, I go onto to check some of the games that I could play (The mac being a power PC, and not being Intel) I download trial just to see how it would work so it downloaded, then I play it. The game begins to work, in fullscreen I then realize that my 'ESC' and my Directinal buttons were not working, so I couldn't get out of fullscreen, or exit the game. After trying the various ''escape'' commands/minimize commands from the keyboard (None of them could work, due to the un-working escape key) so I only have one option, which is just shut the computer down, by holding down the Power button. This turned off the mac, obviously. The next time I tried to turn it on, it didn't work. I press the button I get 2 clicks on the button and nothing else, the little light on the power button does come on, and for longer if I keep my finger on the button.

    Don't worry, all my work, and my files are safe, according to my Dad. I'm planning on backing them all up on his computer. I have tried resetting the PMU/Cude button but that didn't do much. I also tried taking out, and putting the battery back in, that didn't work either. Does anyone know a solution on this? It would be nice to know that it is not broken. Thanks.

    - MrKalius
  2. MrKalius thread starter macrumors newbie

    Feb 8, 2011
    I managed to power it up enough to get the fans working, but it didn't make the chime noise. I'm just getting really angry off now... but it won't get past booting up, I'm pritty sure that this is the Power supply. It has to be. Anyone have any idea how much that will cost?.. *Sigh* My mac, my work, gone.. How annoying. Also, were is the power supply located or how I can get access to it? Thanks guys, I hope you help me. D:
  3. simsaladimbamba

    Nov 28, 2010
    Maybe this can help:

    Btw, you can still access your work when you get access to the HDDs, either via Target Disk Mode (if it works and you have another Mac or Windows PC with Firewire) or by removing the HDD(s) and putting it (them) in an external enclosure for 3.5" S-ATA HDDs.

Share This Page