My Sleep/Wake button Keeps Pressing Itself!

Discussion in 'iPhone' started by BergerFan, Oct 30, 2010.

  1. BergerFan macrumors 68020

    BergerFan

    Joined:
    Mar 6, 2008
    Location:
    Mos Eisley
    #1
    I've had my iPhone 4 for 2 months now, and I love it.
    I've had zero issues, until only a few hours ago, when my Sleep/Wake button would randomly press itself. :confused: Sometimes every 5 mins or so, other times with a longer gap.
    I could be watching a video browsing or whatever, and I'd get the lock sound, along with the screen turning off. Then I'd get the 'slide to power off' option.
    A press of the cancel button ends it, only for the same thing to happen again a few minutes later.
    I'm restoring as I type this on my iPad, to see if that'll fix it, because I've never dropped my phone, and always take care of it.
    If it persists, I'll take it to the Regent Street Apple Store to get a replacement, where the issue will no doubt never happen in there, making me look like an idiot. :(

    Anyone else had this problem?
     
  2. Hunter Kiddo macrumors newbie

    Joined:
    Sep 28, 2012
    #2
    Same Problem.

    My iPod locks itself, unlocks itself, brings up the "slide to turn off thing" and even turns itself on sometimes... but usually turns itself back off somehow before the iPod loads and the apple logo leaves... All I was doing to cause this was locking and unlocking my iPod with normal presses... complete crap that it should do this...

    SOMEONE FIND A WAY TO FIX THIS PLEASE
     
  3. Wr404 macrumors newbie

    Joined:
    Jul 27, 2013
    #3
    I have a fix! (I think! :p) i had this with my ipod touch 4g i think that you must have some dust or something in the switch all i did that has fixed it (for now!) is keep pressing it over and over! simple this worked for me and i hope it works for you! :)
     
  4. AFDoc macrumors 68030

    Joined:
    Jun 29, 2012
    Location:
    Colorado Springs USA for now
    #4
    First guy responded almost 2 years after OP and you took almost a year to respond to him.... I would bet they fixed the issue by now.
     

Share This Page