My sons MacBook won't power on.

Discussion in 'Mac Basics and Help' started by Check Marc, Jul 27, 2010.

  1. Check Marc macrumors newbie

    Joined:
    Jul 27, 2010
    #1
    I'm a Windows person so please excuse me if I don't know the jargon. He had to use the drop down menu to power it off and now he can't turn it on. The power supply tested OK. I'm think that it's the power button and the keyboard needs to be replaced. Is there any thing else to look for?
    .
    Thanks,

    Marc
     
  2. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #2
    Does it power up at all e.g., any lights, chimes, clicking, etc.?
     
  3. Check Marc thread starter macrumors newbie

    Joined:
    Jul 27, 2010
    #3
    It doesn't do anything, no sounds, no clicking chains nothing. That sort of why I'm leaning to it being the power button.
     
  4. Matthew Yohe macrumors 68020

    Joined:
    Oct 12, 2006
    #4
    Did you remove the battery?

    If it's not removable, did you hold the power button for 5 seconds?
     
  5. ziggyonice macrumors 68020

    ziggyonice

    Joined:
    Mar 12, 2006
    Location:
    Rural America
    #5
    Hmm, there's a lot of different possibilities.

    While the power button on the keyboard could be the problem, there could also be something wrong internally. Let's start with the basics (straight from Apple). And if none of these steps work, you might want to contact Apple or visit an Apple Store. Hopefully the computer is still under its warranty.


     
  6. xi mezmerize ix macrumors 6502a

    xi mezmerize ix

    Joined:
    May 24, 2010
    Location:
    Maryland, USA
    #6
    Your son should be the one trying to learn how to fix this...not you.
     
  7. arogge macrumors 65816

    arogge

    Joined:
    Feb 15, 2002
    Location:
    Tatooine
    #7
    I have a similar problem, and it has become somewhat reproducible. If I issue the Shut Down command from the Apple menu and then try to do a cold boot, the power button on the box fails to work. If I cut the power, restore and try again, the power button works. The power button also works to Shut Down and cold boot without using the Apple menu in Finder. It looks like a software or firmware problem.
     
  8. Check Marc thread starter macrumors newbie

    Joined:
    Jul 27, 2010
    #8
    This is DOA regardless. He's tried the reset. From my experience if there was something else wrong something would happen but nothing is. He's taken it apart and tried to clean the power button but that did nothing.
     

Share This Page