iPhone My stealth / spying call recorder streamlined & cleaned up (iPhone 4S/5/5c/5s)

Discussion in 'Jailbreaks and iOS Hacks' started by Menneisyys2, Apr 4, 2013.

  1. Menneisyys2 thread starter macrumors 603

    Joined:
    Jun 7, 2011
    #126
    Currently, there's no solution: see #117

    A bad piece news to the entire thread: I may be losing my JB (see http://forums.macrumors.com/showthread.php?t=1587134 ). Fingers crossed I either get my iPhone5 back unaltered or get a pre-iOS61.3 phone instead.

    That is, I may be not be able to update the hack in the future, that is, before the next JB. Sorry for that.
     
  2. Justinb51 macrumors 6502

    Justinb51

    Joined:
    Apr 9, 2010
    Location:
    Indianapolis, IN
    #127
    Dang man, that sucks! Hopefully you get your phone back!

    Thanks again for all you have done!

    Good luck!!!!
     
  3. Menneisyys2 thread starter macrumors 603

    Joined:
    Jun 7, 2011
    #128
    Just received it back.

    Unfortunately, the bastards installed 6.1.4 on it. That is, no JB for me for a while :( Fortunately I use my iPads a lot more than my iPhone5; that is, the loss of, say, f.lux isn't that acute for me. It would be on my iPad...

    The service personnel stated it was deep discharged but, otherwise, was OK. That is, they didn't swap the battery, only charged it (and restored the phone). This means by the time the phone reached them (late last week? early this week?) it could already be switched on.

    The moral of the story? If you notice the charge level decreases too fast and, after reaching, say, 40%, just can't make your iPhone 5 boot in (all you see is either the DFU mode with backlight or a fading Apple logo), do NOT take it for repair. Just make sure you deep discharge it (by keeping it in the DFU mode, which, as it has backlight on, will drain the battery) and, then, wait a day or two. Or three. (Basically, do what Jakebrown recommended at http://forums.macrumors.com/showpost.php?p=17326905&postcount=34 ) It WILL start working after that.
     
  4. Sethide macrumors newbie

    Joined:
    Jan 17, 2011
    #129
    Thank you for the great app.
    I am using the version 0.2-247 on iPhone5.
    When I use handset, only my mic (so my speech) was recorded.
    Is this a known bug?

    I hope you get your JB back soon on your iPhone5.
     
  5. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #130
    On an iPhone 5, both sides of the conversation should be recorded when using handset.
     
  6. Sethide macrumors newbie

    Joined:
    Jan 17, 2011
    #131
    Sorry I mistyped, I meant headphone (with Mic).
    I tried with and without. With headphone, only the mic way is recorded = The record doesn't show up in the UI and only one file is generated on the file system.
    Without the headphone, everything works as expected.

    Thank you.
     
  7. Menneisyys2 thread starter macrumors 603

    Joined:
    Jun 7, 2011
    #132
    As I've also mentioned in one of my previous posts, the AR is incompatible with the wired headset. Don't even bother with it - it won't work.
     
  8. Sethide macrumors newbie

    Joined:
    Jan 17, 2011
    #133
    Just read it now. Thanks for the quick answer.
     
  9. Mystership macrumors newbie

    Joined:
    Jun 24, 2013
    #134
    Audio Recorder questions please

    Hi all. A couple of months ago I added a repo via Cydia that had a k'd Audio Recorder, that claimed to have the beep removed. It works, however there is still an annoying "thump" sound at the beep intervals.

    When I look at Installed Apps, Audio Recorder doesn't show up for some reason, which tells me perhaps I tossed that particular repo, and I can't remember what it was. All I can remember is the repo had a note about the author being a "weenie" (paraphrasing) because he included the beep in the first place.

    I have NO problem buying the program. I don't usually condone the k'd versions, preferring to pay these great software people for great tweaks.

    I'd like to find another version that has no interval sound at all. I've tried to discover the version of Audio Recorder that I have installed, but I can't find it anywhere. And since I can't remember the repo, I'm not sure how to delete it, and find a better version that makes no sound at all when recording.

    Sorry for the long-winded post, but any help is appreciated.

    M-ship
     
  10. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #135
    A repo doen'st have to be installed to delete a tweak.

    Just go into Cydia/manage/package and hit modify top right, select delete.

    Discussing cracked apps on MR is not allowed. Buy the app and add Menneisyys2's mod.
     
  11. Mystership macrumors newbie

    Joined:
    Jun 24, 2013
    #136
    Actually...

    Actually, a k'd version was discussed early in the thread. As I indicated, I buy my software. There was a good deal of chatter about this app's beeps being removed in this thread. If someone does that, that makes it a k'd app, so I'm not sure aha the fuss is about. Nonetheless, I'll refrain from referring to k'd apps in the future, regardless of the context.

    Second, I also indicated that the app does not show up in Installed Packages, or I wouldn't have bothered to post that. I reasoned that if the repo was removed, the app might not show in "Installed." Perhaps my reasoning is faulty.
     
  12. coolguy79 macrumors newbie

    Joined:
    Aug 1, 2013
    #137
    Can't get this to work for the life of me :(

    Howdy, I first purchased from limneos and everything worked as advertised. I then tried to install the deb from page 1... to do so, I first downloaded it with ifile and installed it on my JB 4s running 5.1.1 (fwiw it's from sprint).

    Ifile hangs once the install is over... for minutes. I did a hard-reboot and the phone gets stuck on the apple logo; it will eventually load, but then I get a message saying that springboard has shutdown and I am in safe mode. I am unable to respring successfully unless I remove the callrecorder.dylib from the mobilesubstrate directory (I use iphonebrowser). Uninstalled everything, tried again, same outcome.

    I then did a clean audio recorder install and I changed the localizable.strings and the warning.caf in the en folder in PreferenceBundles-Callrecorderpreferences... (like the instructions on the bottom of the page). Now the phone still boots & springs with no problems but I get an error message from audio recorder saying that the warning file is missing. I tried all over again and manually changed the localizable.strings file and copied the new caf file in.... same outcome.

    Not sure what to try next, this has tremendous promise... if only I can get it to work!!
     
  13. Menneisyys2 thread starter macrumors 603

    Joined:
    Jun 7, 2011
    #138
    In the current version, callrecorder.dylib must also be swapped for the caf file tampering protection to be circumvented - see http://forums.macrumors.com/showpost.php?p=17135506&postcount=93
     
  14. coolguy79 macrumors newbie

    Joined:
    Aug 1, 2013
    #139
    Thank you for the fast response. I just tried to install that package over a fresh install of the current version, and I ran into the same problem :(

    My phone refuses to boot or even respring with you dylib file... that's why I was trying to go around it... I'm still super enthusiastic about making this work, please let me know if you have any ideas on what I may be doing wrong.

    Again, MUCH APPRECIATED man, this is awesome!

     
  15. Menneisyys2 thread starter macrumors 603

    Joined:
    Jun 7, 2011
    #140
    Dunno why it isn't working and can't really test it as I've lost my jailbreak... Sorry.
     
  16. coolguy79 macrumors newbie

    Joined:
    Aug 1, 2013
    #141
    Bummer thanks anyhow!
     
  17. Sam Brix macrumors newbie

    Joined:
    Aug 6, 2013
    #142
    How to encrypt the timestamp?

    @Menneisyys2

    You encrypt the timestamp with SQL Lite, but it´s not working for mw. Or let´s say I don´t know how to do.

    Can you let me know or show me another way how to read the numbers (timestamp) in the file name right?

    Thanks so much!!

    Sam
     
  18. Menneisyys2 thread starter macrumors 603

    Joined:
    Jun 7, 2011
    #143
    1, you can easily access all the dates using, say, the Firefox plugin "SQLite Plugin". The screenshot at http://forums.macrumors.com/showpost.php?p=17100749&postcount=5 was also created using this tool. Let me know if you have problems installing / using the plugin - it's REALLY simple and very useful to have (not only in this case).

    2, are the filenames the same as the "timestamp" fields in the table? That is, for example, "386191714"? They aren't true Unix timestamps (not even if you multiply them with 1000) but still seem to be similar.

    I can't check the output filenames any more as I've lost my JB.
     
  19. Sam Brix macrumors newbie

    Joined:
    Aug 6, 2013
    #144
    Thanks...with the Firefox Addon it´s working!

    Yes, the timestamp is the number in the file. I.e. 391509706 stands for 2013-05-29 08:42:20 and a duration of 34 seconds.

    Any idea how to convert the timestamp into date, time and duration?

    Thanks
    Sam
     
  20. Menneisyys2 thread starter macrumors 603

    Joined:
    Jun 7, 2011
    #145
    The timestamp is increased by one every second. Right now, it started exactly 12.40619 years ago, which isn't any official timestamp standard. By adding a constant to extend it to the Unix time (70/01/01) it is possible to use standard timestamp conversion tools like http://www.onlineconversion.com/unix_time.htm

    I've done the math. The constant you'll need to add is 978307312 . Just add it to the timestamp and copy the sum to the uppermost field of http://www.onlineconversion.com/unix_time.htm .
     
  21. Sam Brix macrumors newbie

    Joined:
    Aug 6, 2013
    #146
    WOW...thanks so much, man!

    It´s working nicely when I add 978307234 to the actual number in the file name. So I finally could copy all files from my Iphone and delete them to make some more space :)

    With SQL Manager for Firefox I realized two things.
    Even if I have 1613 CallMic and 1546 CallSpeaker files (so 3159 in total) the database just shows me 1535 calls.
    Also the calls in the database are exactly 2 hours earlier as they really are. But the app (CallRecorder) shows the right time.

    Could there be a database problem?
     
  22. Menneisyys2 thread starter macrumors 603

    Joined:
    Jun 7, 2011
    #147
    I dont think so - CR may be applying your time zone setting. Are you in CET?
     
  23. Sam Brix macrumors newbie

    Joined:
    Aug 6, 2013
    #148
    Yes, it might be a different time zone.

    Also about the different number of recordings got some more clue in the meanwhile. 2 recordings is 1 call (1 for the caller and 1 for the called one).
    Still I don´t understand why there´s a significant difference in the actual recordings (3159/2=1579) and the calls shown in the database (1535).

    Anyway this is a minor problem. Basically the main problem is solved - to save the calls on my Mac and then be able to find them again and check what date and time they´ve been made.

    Thank you very much man. Your help is very much appreciated!!!
    Without you I wouldn´t have been able to do that.
     
  24. Menneisyys2 thread starter macrumors 603

    Joined:
    Jun 7, 2011
    #149
    Are the mic recordings without speaker peers calls that haven't been answered?

    (Can't test right now whether recording starts on the dial tone. On Symbian - the OS I had to return to be able to record calls after losing JB on my iPhone 5- , it's certainly possible to start recording that early.)

    ----------

    You're welcome :)
     
  25. Sam Brix macrumors newbie

    Joined:
    Aug 6, 2013
    #150
    Right! It seems like this.
     

Share This Page