my touch bricked itself! Help please

Discussion in 'iPod touch' started by WLS, Nov 20, 2008.

  1. WLS macrumors 65816

    Joined:
    Jul 10, 2008
    #1
    My touch just stopped working. I did a sync and all of a sudden it bricked!
    now it just shows the apple and itunes does not recognize it.
    I've tried holding down the power switch and the thumb button and I can force it to shut down but when I start it up it just shows the apple. Itunes says it can't find it so how can I do a restore?
    I've had this since January so is it still under warranty??? I sure hope so. Any helpful suggestions appreciated.
     
  2. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #2
    there's a 1 year warranty. Call Apple or take it to the applestore.
     
  3. blackbelt534 macrumors regular

    Joined:
    Oct 3, 2008
  4. iP0t macrumors newbie

    Joined:
    Nov 19, 2008
    Location:
    Melbourne
    #4
    If you tried to jailbreak it then your warranty is void :apple:.
     
  5. Airforcekid macrumors 65816

    Airforcekid

    Joined:
    Sep 29, 2008
    Location:
    United States of America
    #5
    If you jailbroke it your only chance is dfu mode if not take it to apple.:apple:
     
  6. WLS thread starter macrumors 65816

    Joined:
    Jul 10, 2008
    #6
    Now its working!

    I'm glad to hear I have a full year warranty. No it was not jail broken.
    Thanks for the link about DFU mode- that would be my next step to try but
    strangely after just letting it set for a while connected tonight it suddenly started working again. Seems to be OK now but it had me going for a while there.
     
  7. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #7
    mines done that before and it wouldn't start up and after leaving it alone for a while it fixed itself and started again! :D
     
  8. beeh macrumors regular

    Joined:
    Jan 15, 2008
    #8
    Maybe the battery was completely drained? That happened to mine once and I thought it was a goner, but when I plugged it in, it started charging and I noticed the battery was completely discharged.
     
  9. WLS thread starter macrumors 65816

    Joined:
    Jul 10, 2008
    #9
    I noticed that also- the battery showed red for discharge and then after a while it got charged and was working. Thing is though the battery was not discharged when it stopped working but it seemed like after it was bricked it had to completely discharge in order to clear the problem.
    Its working now and upgraded to firmware 2.2
     

Share This Page