My touch says firmware is current

Discussion in 'iPod touch' started by SirJ, Jul 11, 2008.

  1. SirJ macrumors member

    Joined:
    Apr 29, 2008
    #1
    Hey guys, sorry to further inundate this board with posts but this one is a little different.
    I was on itunes clicking the 'update' button in hopes that it would magically work and after a while it stopped the error message and said
    "This version of the iPod software (1.1.4) is the current version"

    help?
     
  2. Heraklitus macrumors member

    Joined:
    May 30, 2008
    Location:
    El Cerrito, CA
    #2
    Quick! Someone start yet another thread!

    We're all getting the same thing. Chill.
     
  3. Squires macrumors regular

    Squires

    Joined:
    Jun 9, 2008
    Location:
    Manchester UK
  4. SirJ thread starter macrumors member

    Joined:
    Apr 29, 2008
    #4
    i realize that, yes it's another dumb 2.0 post that i've been reading all morning but i hadn't seen this problem yet and was worried
    no longer though, back to normal. error and all.
     
  5. AceFernalld macrumors 65816

    AceFernalld

    Joined:
    Mar 3, 2008
    Location:
    Massachusetts
    #5
    This problem is EVERYWHERE on these threads, everyone is getting it.
     
  6. atomheartmother macrumors regular

    Joined:
    Aug 27, 2006
    #6
    It's been bumping back and forth between 2.0 being available and 1.1.4 being current for me. This is why I don't believe the problem is simply overloaded servers. Apple has seriously f'cked up on their end.
     

Share This Page