My Trash Won't Empty

Discussion in 'Mac Basics and Help' started by dwascou, Jan 19, 2006.

  1. dwascou macrumors newbie

    Jan 19, 2006

    I have a Powerbook running OS 10.2.8 All of a sudden, my trash just won't empty - anything, locked, unlocked, anything at all. I've reset permissions, still, nothing. I did manage to empty my trash via a program called Cocktail, which I know some of you guys are familiar with, but it is striking me odd that I just can't empty the trash the good old fashion way.

    Anyone have any guesses or suggestions?


  2. iPhil macrumors 68040



    If a file is IN-use while you trashed the app from finder, the trash won't delete it so quit the app then try again..

    edit: try holding option key while emptying the trash
  3. dwascou thread starter macrumors newbie

    Jan 19, 2006
    Yeah, great suggestion, but that's not working out either. I could be running just the Finder and trash STILL won't empty. It won't empty anything at all.

    Thanks for the advice though!

    Any other thoughts?
  4. Sogo macrumors 6502

    Jan 4, 2004
    Yea, I recently had a file that refused to be deleted, so i used trash it and it went away!
  5. dwascou thread starter macrumors newbie

    Jan 19, 2006
    The thing is, it's not just one file - its ANYTHING.

    Even after I use Cocktail to delete something, the next time I put ANYTHING in the Trash Can, I can't delete it. I can't delete anything from the tiniest text file up to an application - nothing.

    So it's not a stubborn file - its the trash application itself.

    But thanks for the suggestion! Any other ideas?
  6. iPhil macrumors 68040



    Try the option key while emptying the trash first, if then that doesn't work then go for Trash it @

    the trash it link is from sogo.. not me :eek: :eek:
  7. jtalerico macrumors 6502

    Nov 23, 2005
    instead of putting it into the trash, open up a terminal and do the rm command.

    > rm filename

    if that does not work do this..

    >rm -rf filename
  8. dwascou thread starter macrumors newbie

    Jan 19, 2006
    I'm not familiar with opening a terminal and doing a rm command. Will this then allow my trash can to work in the future?

    I really should stress that it's not a specific file or files that is giving me the issue - its the actual trash application itself. I'd like to get it working so that I can just toss stuff into the trashcan and hit empty trash.

    Do you think that if I upgraded my operating system to the current OS that I might be able to use the trash can again versus using programs like Cocktail or doing things like your above advice of opening a terminal?

    Thanks for the help!

  9. frankblundt macrumors 65816


    Sep 19, 2005
    South of the border
    if you open the trash and Get Info on it are the permissions read & write for everyone? if not you'll need admin access to rest them.
  10. frankblundt macrumors 65816


    Sep 19, 2005
    South of the border
    and check the permissions for the .Trash folder in the root of your User folder too (search with invisble items turned on). You should be the owner with read & write, group and others = No Access.
  11. Epicurus macrumors 6502


    Apr 28, 2005
    Minneapolis, MN
    I had that problem once. Every time I told it to empty the trash I could hear the little sound play, but the files stayed put. A simple reboot fixed it for me. :D
  12. dsap4004 macrumors newbie

    Apr 16, 2008
    I know it's been a while since anyone has written a reply to this thread but I had the same problem with version 10.5.2. The trash just wouldn't empty any file. All I had to do was open the trash folder, right click, and under more, click enable folder actions. Maybe you got it fixed already but I didn't see a post about enable folder actions and that's what worked for me.
  13. entwurf macrumors newbie

    Jul 25, 2008
    OSX Leopard Trash won't empty

    I had the same problem, from my OSX partition i trash a file from the XP partition into the mac trash, then after, i didn't want to empty!

    The solution was really in my face :eek:, i took the file from the trash back into the XP partition and it disapeared.

    That's it

  14. nomy macrumors newbie

    Sep 13, 2008
    I am new to mac, this is old thread but i am still unable to solve this problem of emptying my trash. i have tried things mentioned in this thread but
    somehow trash bin wont empty.
    Although i am able to empty it through terminal commands and third party program.
    Any suggestions would be welcomed.
    Many thanks.
  15. Qussai macrumors newbie

    Sep 28, 2008
    For me , i tried all the above methods but my Trash is still full.

    any help? i have also MAC OS X 10.5
  16. durija macrumors 6502

    Jan 16, 2008
    Just today, I could not empty the trash. I was logged into my everyday user account, which is not an administrator. I could not even open the Trash most of the time, and even then I could not select anything to "Get Info". Actually locked up to the point where only the power button got me out of it.

    I changed the account to an administrator, and voila, trash be gone! I'm paranoid about security, but I think I'll have to just live with being an administrator at all times. Might work for someone else. Who knows?
  17. Trip.Tucker Guest

    Mar 13, 2008
    Open a terminal.
    cd .Trash
    rm -fr . (or rm -fr * )

    Open Disk Utilities
    Repair permissions that order.
  18. eloisemcnulty macrumors newbie

    May 19, 2009
    I had the same problem

    I had the same problem, and nothing seemed to work. Then I found this great web page, which I have forgotten (sorry), but I do remember how to fix the problem.

    This technique uses a hidden feature of Mac OS X to force the Trash to empty.

    1. Press and hold the mouse button on the Trash icon in the Dock. The context menu for Trash will display.
    2. Press and hold the Option key (Alt key).
    3. Select Empty Trash from the context menu for Trash.
    4. Release the Option key.

    Hope this helps.
  19. karuha macrumors newbie

    Jun 23, 2009
    trash your bin completely!

    open terminal and type this: rm -rf ~/.Trash/* and hit enter or return
  20. krayziekray macrumors 6502

    Sep 24, 2008
    This ^^^ ;)
  21. coolboypie macrumors newbie

    Oct 3, 2009
    i have the same problem

    hey mine dosent empty it get half way and stop nomatter what files i try :mad:
  22. coolboypie macrumors newbie

    Oct 3, 2009
    sor i just fixed it thanks this really works
  23. afteryouwho macrumors newbie

    Dec 31, 2007
    This worked for me like a charm

    I was going nuts trying to empty my trash and this fixed it in a flash.

    Just to elaborate in hopes to help:
    I am running Snow Leopard on a MacBook.
    Suddenly when I went to empty the trash, I got a popup that gave me the option to do a secure empty. I had been doing this all the time but then I got a message saying that some files were locked (by whom?) and did I want to delete all files or only unlocked ones. I clicked on all files and then the emptying files pop up appeared, listed the number of files to delete and then disappeared without doing anything.
    I followed the above advice and my trash is now empty.

    Go figure.

    Thanks again.
  24. jman995x macrumors regular

    Sep 8, 2007
    I finally was able to empty my trash after trying everything listed above.

    Here's all of the things that didn't work (for me), and the odd thing that I did that did work:

    I kept getting the error message: The item ".Trash" is in use right now and cannot be opened.
    I was about to lose my mind.

    • I have a program called "Smart Trash"...nope.
    • I tried "Super Empty Trash"...nope.
    • I ran some terminal commands followed by a Repair Disk Permissions...nope.
    • Option-Empty...nope.
    • I booted VMWare Fusion / XP, and did a CHKDSK...nope.
    • I tried creating an empty folder and dragging the files (17 of them) into the empty folder, then deleting the empty folder, but my computer wouldn't let me pull the files out of the trash and move them to the new folder.
    • I put the files into A Better Finder Rename and tried to rename them...nope

    Then, I did something that you'd never think would solve the problem, but for some reason it did.

    I opened up the trash, did a Cmd-A to select all, then a Cmd-I to find out how (collectively) big all of these files were and when my Mac tried to access the files to see their size, they disappeared.
    I have no idea why that was the thing that worked, but my Trash is empty and the paper in my trash icon is gone.

    Just thought I'd share this because I know there are others out there that have tried everything as well. I'm not promising this will work for you, but what have you got to lose, right?

  25. Gregg2 macrumors 603

    May 22, 2008
    Milwaukee, WI
    Your Mac: What files???

Share This Page