My Wifi has become spotty at best... Need help

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Mjmar, Jun 3, 2009.

  1. Mjmar macrumors 65816

    Joined:
    May 20, 2008
    #1
    I have had my 1st gen iphone for a year and a half now, and lately my WiFi has been causing me a lot of trouble. It started right when I got a new netgear router, so I'm assuming that's the problem... The router runs 802.11n and g simultaneously. Obviously the iPhone uses g. But when I do connect it stays connected for about 1 minute, and then starts going on and off... The majority of the time there's only 1 service bar and I'm literally 10 feet from the router... It used to work fine, but now it doesn't. Does anyone know how to fix this? thanks
     
  2. henchosbandito macrumors member

    Joined:
    Jan 24, 2008
    Location:
    Somewhere between 10 and 11
    #2
    'spotty' wifi signal?? Im guessing Clearasil should clear that right up :p

    Sorry, had to be done... However, i would suggest seeing if you can find an 802.11g only setting to see if the connection improves. It shouldn't do because my time capsule runs both n and g and i have no problem.

    Alternatively, see if you have any other wireless devices and see if they suffer from a similar problem.

    Let us know how it goes.
     
  3. Mjmar thread starter macrumors 65816

    Joined:
    May 20, 2008
    #3
    Actually now that I remember, the WiFi also didn't work well at my friend's house... Same as mine. If it is the phone, what can I do. Will restoring help?
     
  4. henchosbandito macrumors member

    Joined:
    Jan 24, 2008
    Location:
    Somewhere between 10 and 11
    #4
    I think the first thing to do would be to go Settings>General>Reset>Reset Network Settings.

    If this doesnt fix the problem, i would try shutting down the phone, starting it up and trying again. If this doesnt work, thats probably when you should go to the factory reset. Failing that, genius bar my friend.
     

Share This Page