My Yahoo stopped pushing

Discussion in 'iPhone' started by cjandnw, Aug 28, 2007.

  1. cjandnw macrumors 6502

    Joined:
    Jun 11, 2007
    Location:
    South Jersey
    #1
    Is this an iPhone issue,
    a Yahoo issue or
    an AT&T issue?
    I reset twice and yahoo has not pushed since Friday 8/24.
     
  2. d21mike macrumors 68040

    d21mike

    Joined:
    Jul 11, 2007
    Location:
    Torrance, CA
    #2
    I have had these problems. Not sure who is at fault.

    Do you get mail when you go into the inbox? If not, are you getting "Connecting" or "Checking for Mail ...".

    I find when not pushing that I need to go into a diffent folder (like Sent) then back into InBox. Some have said that turning of WiFi and only using Edge helps but that has not been my experience. You may want to delete the Yahoo Account and then re-add but only use Edge when doing that.
     
  3. cjandnw thread starter macrumors 6502

    Joined:
    Jun 11, 2007
    Location:
    South Jersey
    #3
    When I go to the inbox i make it check a couple of times then i get all of the missed messages. It takes a few attempts for it to update. I'll try the delete and re add the account while on edge.

    Thx
     
  4. d21mike macrumors 68040

    d21mike

    Joined:
    Jul 11, 2007
    Location:
    Torrance, CA
    #4
    I know you said you did this, but when this happens I normally just POWER OFF and POWER ON (only holding down button on top). After which it starts Pushing again. If it just sets there with "Checking for Mail ..." then I have found that I need to delete the oldest email in my InBox.
     
  5. Pattycerts macrumors 6502

    Joined:
    Jul 4, 2007
    #5
    Yahoo push on the iPhone is a joke, so bad IMO that they shouldn't be allowed to call it push. Even when it is "working" there are lags, and regardless I now open my email and manually check all the time, assuming its not working. Very surprised and disappointed w/it considering Steve touted this feature from day 1
     
  6. d21mike macrumors 68040

    d21mike

    Joined:
    Jul 11, 2007
    Location:
    Torrance, CA
    #6
    I understand your frustration. I have been pretty upset over the last couple months. I got my phone 1 week after release and have been fighting with it ever since. However, since this is my first email phone I don't have a lot to compare it to. My understanding is that BlackBerry is pretty solid and I am hoping that Yahoo and Apple can get this nailed down.

    On the other hand, I love the iPhone and when the Email works I could not imagine any other device that I would rather have. In my earlier Posts I explained some of the tricks I use when having problems. They seem to work pretty well. You might want to give them a try.
     
  7. Pattycerts macrumors 6502

    Joined:
    Jul 4, 2007
    #7
    I have done them also, but they are short-term. Apple needs to fix this soon.

    Even MS exchange has a "heartbeat," which will initiate a sync every x minutes (depending on the servers settings) if there hasn't been any activity. I've had emails for over an HOUR before I remembered to check, and certainly more overnight.

    I have since gone back to gmail-autosync. With yahoo you can't even choose this, its PUSH only! What a joke! No, its not the end of the world and I am not returning my iPhone because of it, but it just reiterates that Apple is a consumer-based company with no understanding of the business user..
     
  8. d21mike macrumors 68040

    d21mike

    Joined:
    Jul 11, 2007
    Location:
    Torrance, CA
    #8
    Upgrade to Yahoo Mail Plus

    I decided to pay the $20 per year and get Yahoo Mail Plus. The reason is that I mainly wanted to remove the advertising and add some of the Plus features. One of the features is POP support which I may use consider using.

    However, not sure it is related, but I have NOT had any failures (discussed below) since moving to Mail Plus on Monday at 3pm pst. Kind of early to make any predictions since I have went for a few days before without failures in the past. Also, maybe Yahoo is improving things with the rollout of their New Email system this week on new servers. However, my account has not been move to the new servers since I am still on the old beta. Again, may not be related.
     
  9. eye.surgeon macrumors 6502

    Joined:
    Jul 12, 2007
    Location:
    California
    #9
    I've been a yahoo plus paid user for a couple years and have been using it on my iphone since release day. I find the push feature to be sporadic. I am hoping this is addressed ASAP. I can always manually fetch my mail but don't always get a push.
     
  10. 7racer macrumors regular

    Joined:
    May 3, 2004
    #10
    I have the yahoo plus feature also but due to my ATT/sbcglobal account.

    It was all working great until the last update (I think) when I totally lost the ability to send emails.

    SOMEONE needs to address this ASAP! GRrrr
     
  11. d21mike macrumors 68040

    d21mike

    Joined:
    Jul 11, 2007
    Location:
    Torrance, CA
    #11
    Stopped Pushing this morning after working grate since Monday.

    This time I did my normal of deleting the oldest messages. That did not work right away so I switched to WiFi and it started working again. Not sure if WiFi helped or just timing.

    Now receiving mail via Push.
     
  12. Rodimus Prime macrumors G4

    Rodimus Prime

    Joined:
    Oct 9, 2006
    #12
    the problem with Yahoo Push mail is it is a not a true push mail. Instead of pushing the email to your iphone instead it sends a text telling your phone to poll server and check for mail then download it.

    True push will put the email on your phone with out ever logging into the server. Yahoos your phone has to log in to get it.
     
  13. d21mike macrumors 68040

    d21mike

    Joined:
    Jul 11, 2007
    Location:
    Torrance, CA
    #13
    The problem with "True" Push is that the mail client needs to always be connected to the server and what I understand is that it must keep a heart beat going to that it does not time out. So if you get very little email I would think the 1st method would be better (where the phone is told to login and get the email) and if you get a lot of email then the second method would be better where it stays connected.

    I honestly would not care how it works for now as long as when my mail hits the server it hits my phone very soon there after.
     
  14. Rodimus Prime macrumors G4

    Rodimus Prime

    Joined:
    Oct 9, 2006
    #14
    you do not need to be always connected to the server. The blackberry does not always stay connected to the server. The push mail method has a much less draw on servers. the only thing the mail server needs to know is if you phone can take a text message. When the phone is off it will get teh emails as soon as it is turned on again.

    The way yahoo is doing is a poor work around for push.
     
  15. karenmb macrumors newbie

    Joined:
    Aug 14, 2007
    #15
    I noticed my Yahoo hasn't been "pushing" at all. I logged into my email accounts tonight at work, and it showed the last update hours ago...like the last time I logged into email!
     
  16. drater macrumors 6502a

    drater

    Joined:
    Oct 6, 2005
    Location:
    Boston, MA
    #16
    been doing the same to me. sucks. hope they fix that soon. really annoying and missing a lot of emails that could use timely responses
     
  17. iPhoneyboy macrumors member

    Joined:
    Jul 19, 2007
    #17
    I have the opposite problem. My Yahoo push's all the time.... and I wish I could turn it off... so it only pull's. I have a couple email accounts and they're set to "Auto-Check Manually". But the Yahoo is always in "push" mode. Is there anyway to set it as "pull" only?

    It's a secondary address that I don't need to check very often.

    Thanks.
     
  18. drater macrumors 6502a

    drater

    Joined:
    Oct 6, 2005
    Location:
    Boston, MA
    #18
    ok, i called apple support on the yahoo and other mail issues. The guy told me that it is probably the network with att. So what he had me do was turn on airplane mode for about 15 seconds. Then turn it back on, do a soft reset and see what happens...so far it has fixed it. I sent an e-mail from another account on my computer and it gets to me in a seconds...hope this helps...we'll see if it continues to work
     
  19. d21mike macrumors 68040

    d21mike

    Joined:
    Jul 11, 2007
    Location:
    Torrance, CA
    #19
    You could set that Account "OFF" in Settings / Mail / yahoo account /. The set to "ON" whenever you want to check it.

    Or, you could buy Mail Plus ($20 per year) and you would be able to use POP to access the account. I have not tried it but I believe you can set it up under "Other" as POP.
     
  20. d21mike macrumors 68040

    d21mike

    Joined:
    Jul 11, 2007
    Location:
    Torrance, CA
    #20
    Thanks. Have not tried the Airplane Mode trick. Always looking for a new trick.
     

Share This Page