MyBook Premium = Not Mac Friendly?!?!?

OldSkoolNJ

macrumors 6502
Original poster
Jul 10, 2006
384
0
Ok so I recently bought a 1tb MyBook Premium and a 500gb MyBook Premium to hook up to my 24in iMac. I wanted to go firewire 800 the whole thing. Now normally I do my research before buying but never heard any complaints about these drives and have had some before. However I only hooked up through firewire 400. So I try to plug these in and nothing. Now I swithed em around and tried different cabls but nothing. Ok ... bad firewire 800 port. Off to AppleCare. Nope nothing wrong with it. I try to use 400 or USB and everything is dandy. So I look around on the net about WD MyBooks and using firewire 800 on a mac. Apparently you can not have two WD MyBooks hooked up using firewire 800 on a mac at the same time. It is a known problem by WD and many many places on the web. All they say is either use USB, 400 or return it. So me not knowing a lot about how this works I want to know what is causing the problem. SO can someone explain it to me or know of a fix? I know there are others I can exchange them for but the prices arent bad on these and they just look so nice next to my imac. :D

SO if anyone can add here I would appreciate it.

Kevin :apple:
 

brucewayne

macrumors regular
Nov 8, 2005
123
111
I have 2 WD MyBook 1TB premiums connected via firewire 800 to my iMac 24" 2.8ghz and have no issues at all.

I did do a firmware update (on the WD site) when I bought them in May.

The only issue I have is that they go to sleep almost immediately making them slow to respond sometimes.
 

Sean Dempsey

macrumors 68000
Aug 7, 2006
1,617
3
If I were you, I would buy the Mercury Elite Aluminum external drives from OWC at Macsales.com. I have dual 500gb FW800 drives daisy chained to mine and they work great.

I don't think I'll ever buy an external that isn't an OWC. Look great, run great.
 

mbalson

macrumors member
Aug 16, 2007
56
0
Toronto, Ontario
I have the same issue with my new iMac not seeing my MyBook Premium over Firewire. However I am in the process of backing everything up in preparation of a WD firmware update that I just downloaded. I suspect this will correct the issue.
 

Bobby Garcia

macrumors newbie
May 6, 2006
23
0
Jersey
Ok so I've loaded the most recent Western Digital firmware and still nothing.
... I am having the same problem. Except the MyBook Premium 320 GB will not turn on, through a FW 400 port??? This is the first time I hooked anything up to it. I noticed you said you cannot have 2 WD HD's connected simutaneously... Well, yesterday before I bought the premium, I bought the "Essential" edition which has no FW connection, only USB. I hooked it up, it worked fine...I transfered audio files...just to find out Digidesign (Pro Tools) does not support external USB devices...so off to return, and upgrade to the FW version.

Do you think that may be why it will not turn on? Becuase I previously had the essential edition installed?

Any help would be appreciated, thanks in advance.
 

julianps

macrumors member
Aug 6, 2006
75
2
Wales, UK
Lovely MyBooks

Have 5 of them; love 'em.

Only thing is 1) you must follow the onsite instruction carefully to reformat them for Mac (why, oh why are these instructions not in the box?); and, 2) you must download the Button Manager from their website to get full power control (ie unmount = off) functionality.

Every now and again I have one hang or refuse to play and simply pulling the power and reconnecting it seems to reboot the system inside :rolleyes:
 

Shreedhan

macrumors newbie
Aug 28, 2007
16
0
OMG this exactly what i have. I got a base 24-inch aluminum imac. the firewire 400 port doesn't work. In system profiler only the FW800 shows, nothing about FW400.

I have a MyBook Premium 500GB and it connects via USB but NOT via FW400. It's so annoying. I've tried resetting PRAM, SMC but still nothing, does anything work?
 

oduinnin

macrumors regular
Aug 3, 2007
139
0
Planet Earth
It ain't My Book!

From reviews I've read on the web, I wouldn't bother trying to connect a WD Mybook to a Mac. Period.

Go get an OWC drive or LaCie or Seagate. They are all price competitive. OWC and LaCie come preformatted for Mac. :)
 

kellygeorge

macrumors member
Aug 29, 2007
40
6
KCMO
boycott WD

i have a powerbook and an imac. i bought a 500 gig mybook to back up to and after a week the computers stopped recognizing it. i returned it, and got a 250 gig mybook, this time with firewire. after 5 months the hard drive has stopped spinning. whatever you do, dont get a mybook.
 

Flobber88

macrumors regular
Jun 19, 2007
100
0
When I bought my 500gb My Book Pro, I plugged in the FW 400 cable in for the first time, and it seemed to mess everything up. I read the instructions and it said that for the FW drivers to be properly installed, you should first plug the USB cable into your computer and then you may use the FW after it does its thing. I reformatted the HD back to its original state (downloaded something off the WD site) and followed the instructions and everything is working smooth now.
 

oduinnin

macrumors regular
Aug 3, 2007
139
0
Planet Earth
When I bought my 500gb My Book Pro, I plugged in the FW 400 cable in for the first time, and it seemed to mess everything up. I read the instructions and it said that for the FW drivers to be properly installed, you should first plug the USB cable into your computer and then you may use the FW after it does its thing. I reformatted the HD back to its original state (downloaded something off the WD site) and followed the instructions and everything is working smooth now.

Too many special instructions for Mac users to follow! ;)
 

plinden

macrumors 68040
Apr 8, 2004
3,969
3
I have a 500GB MyBook that worked fine for over a year, but the HD died last week (luckily I duplicate all my data to another drive every few days so I didn't lose much.) But, I think I must be psychic. I hadn't duplicated the drive for a few days, but just before it died, and just after I downloaded the 300 photos we took during vacation last month and deleted them from the camera, I copied them to a laptop. Otherwise I would have lost them. I've never done that before.

Anyway, after a bit of foostering around I got the drive enclosure open (easier than an iMac but harder than any other enclosure I've used) thinking I would just replace the drive. I tested the drive in another enclosure to confirm that it was in fact the drive and not the enclosure, then went to put a new drive in. But although the drive is SATA, the enclosure doesn't have SATA power. The drive needs to have a legacy power connection and as far as I know, those aren't common (I may be wrong - but I haven't noticed them on any other SATA drive). Instead I got a cheap $30 enclosure from CompUSA until the one I ordered from OWC arrives.

So although I would say the MyBook is fine and works well with the Mac (any drive can fail at any time - but the odd thing is, I've had three drive failures in the last year, but NONE in 20 years of using computers before that), do try something else.
 

theBB

macrumors 68020
Jan 3, 2006
2,455
3
I remember reading that WD MyBooks don't have unique firewire IDs or something of that sort that prevents daisy chaining. I don't whether that becomes an issue if you hook two of them to two separate Firewire ports on your Mac.
 

Eric Piercey

macrumors 6502
Nov 29, 2006
266
4
Perpetual Bondage
I've got 2 1TB MyBookPro II's and they suck. Period. You're WAY better off buying yourself your own enclosures and to heck with both RAID 0 and 1 altogether. RAID 0= twice the chance for failure for moderate gains in performance. RAID1 = half the storage capacity for the same ore more money. Just get two regular drives and backup one with the other, which you keep disconnected when not actively backing up. Far more reliable, imo.

I've posted enough about why WD is a horrible company and I'm not in the mood to do it again. Suffice it to say the assembly sucks, the support is abysmal, the firmware upgrade can abort itself while flashing. The fans are mounted upside down in the enclosures.. they're just junk. Period. I'll never buy another WD product again.
 

BlackMax

macrumors 6502a
Jan 14, 2007
901
0
North Carolina
... I am having the same problem. Except the MyBook Premium 320 GB will not turn on, through a FW 400 port??? This is the first time I hooked anything up to it. I noticed you said you cannot have 2 WD HD's connected simutaneously... Well, yesterday before I bought the premium, I bought the "Essential" edition which has no FW connection, only USB. I hooked it up, it worked fine...I transfered audio files...just to find out Digidesign (Pro Tools) does not support external USB devices...so off to return, and upgrade to the FW version.

Do you think that may be why it will not turn on? Because I previously had the essential edition installed?

Any help would be appreciated, thanks in advance.
My wife is using the MyBook Premium 250 GB through FW 400 and had the same problem. It was working fine for three months and then one day it went to sleep and we couldn't get it to wake up. Finally after disconnecting it, removing the power cable, turning off her Power Mac, plugging the MyBook back into the FW 400 port, connecting the power and turning her Power Mac back on it started working again. Perhaps this routine might work for you. That was a few weeks ago and it is still working now.

I'm thinking there is something flaky with the sleep function on the MyBook and it just doesn't wake up properly sometimes. Next time I'll probably buy her an OWC Mercury Elite Aluminum. It costs a little more, but everyone who has them swears by them.
 

smurfy

macrumors member
Aug 6, 2007
61
0
If I were you, I would buy the Mercury Elite Aluminum external drives from OWC at Macsales.com. I have dual 500gb FW800 drives daisy chained to mine and they work great.

I don't think I'll ever buy an external that isn't an OWC. Look great, run great.
Wow, that will surely help a guy who's already bought a drive, huh.
 

compuguy1088

macrumors 6502a
Sep 3, 2007
883
14
In the Sub-Basement of Solitude
I have a MyBook Essenial Edition 160gig drive, and it seemed to work fine (though it has no firewire ports :(), though its NTFS formatted. The other issues is with ntfs3g not working with it, but that is a different story...