MySQL 4 on 10.6 Server?

Discussion in 'Mac OS X Server, Xserve, and Networking' started by multinix, Oct 20, 2010.

  1. multinix macrumors newbie

    Joined:
    Sep 5, 2010
    #1
    Hi all,

    I'm trying to roll out a new 10.6 server (64-bit) but have this piece of legacy software that is holding things up. It depends on MySQL 4.

    I guess my question is, is it even possible to install MySQL 4 on Snow Leopard Server, and if so, how would one go about it? I know 10.6 comes stock with MySQL 5.

    (and yes, I know MySQL 4 has reached its EOL, but the software maker hasn't caught up with MySQL 5 yet)

    Advice is appreciated.
     
  2. Cromulent macrumors 603

    Cromulent

    Joined:
    Oct 2, 2006
    Location:
    The Land of Hope and Glory
    #2
    You should be able to compile a version of MySQL 4 from the source code without many problems.
     
  3. multinix thread starter macrumors newbie

    Joined:
    Sep 5, 2010
    #3
    The only copy I have is 32-bit (i686) - 4.1.19 - and this machine is x86_64. I can't seem to find a copy of the MySQL 4.x source code. All downloads I see are for 5 and up.

    Any ideas? Suggestions?
     
  4. maxplus macrumors newbie

    Joined:
    Dec 6, 2006
    #4

Share This Page