Myst III Exile DVD on Intel Macs?

hauntedcity

macrumors member
Original poster
May 4, 2007
80
0
I have a copy of the Myst 10th Anniversary DVD set, which includes Myst III: Exile. It includes version 1.27, which has instructions for Mac OS X. I can install and run the game successfully, but the sound is jumpy. The video is smooth and looks great.

The only sound item in the release notes suggests turning off virtual memory, which I don't think is even possible in 10.4 Tiger. I can't see how this would be a problem, since my HW specs are far beyond what was state-of-the-art when this game was released.

Anybody have the same problem or know of a solution? I have a MBP (Core 2 Duo, 2.16 GHz, I think) that is patched up to the most recent everything via Software Update.

Thanks,
Doug
 

demallien

macrumors regular
Oct 13, 2005
137
0
Hmmm, I don't know, but I have the same DVD at home. I'll try it out on my MacBook tonight and let you know if I have the same problem, and if I found a solution.

From memory, there is a setup option which allows hardware or software handling of graphics/sound, which can cause problems if you don't select the right option...
 

Mackilroy

macrumors 68040
Jun 29, 2006
3,614
58
The problem would be that Exile is a PPC program, and you have an Intel computer. Performance ain't going to be that great in some games, and it seems Exile is one of those.
 

Eric5h5

macrumors 68020
Dec 9, 2004
2,408
417
The problem would be that Exile is a PPC program, and you have an Intel computer. Performance ain't going to be that great in some games, and it seems Exile is one of those.
If you read the post again, you'll see that the video is smooth; it's not a performance issue (the game runs fine on slow G3s ;) ). This actually happens on PPC Macs too, no matter how fast they are, if they have more than one CPU. The problem goes away if you temporarily disable one of the CPUs. Not entirely sure if you can do that on MBPs, but I would assume so...this requires installing the developer tools if you haven't already.

--Eric
 

Mackilroy

macrumors 68040
Jun 29, 2006
3,614
58
I've had it happen with only one CPU enabled, not just two/four/eight/however many you have. It varies from game to game.
 

hauntedcity

macrumors member
Original poster
May 4, 2007
80
0
Well, I tried downloading the developer tools and disabling 1 of the CPU cores, but I still have the same audio problems. I also tried running the PC version in Parallels, but I get errors saying the resolution isn't supported. :confused:

Unless anyone has a brilliant solution, I suppose I'll have to use Boot Camp. Anyone? :)

Doug
 

hauntedcity

macrumors member
Original poster
May 4, 2007
80
0
Update... I tried running in Boot Camp and I got the same error saying the game's resolution and color depth are not supported! :confused:

Recap:
- If I try running in OS X, the video looks great, but the audio is too choppy
- Disabling one processor core makes no difference
- If I try running in Parallels (XP Home), the game won't even start
- If I try running in Boot Camp, the game won't even start

Any other ideas? Do I have to give up and just get the new Cosmic Osmo game from Cyan? :)

Doug
 

bokan

macrumors newbie
Aug 16, 2010
1
0
Sorry for the huge necro, but the site linked for the sound fix appears to be offline. Does anyone have a mirror?