mysterious hard drive issues...PLEASE HELP

Discussion in 'Mac Basics and Help' started by katedorsey, Jul 14, 2010.

  1. katedorsey macrumors newbie

    Joined:
    Jul 14, 2010
    #1
    Hi all -

    I'm off to the shop to ask an expert in person this afternoon but I'm all about instant gratification so I thought I'd ask around and get a little more information before I go.

    I have a perfectly good western digital external hard drive that earlier this week had a collapsed usb port. I took it in because the case needed to be replaced. Let me emphasize that prior to the usb port being messed up, the drive functioned fine (and is less than 6 mo. old). Even the morning that the port collapsed, when I plugged in the usb cord and held it just right, the volume would mount.

    Fast foward, I take the HD in, they replace the chassis, everything works out fine. The computer guy calls me at some point to ask if I use a mac, I say yes.

    When I picked up the HD yesterday evening the technician told me that he had successfully mounted the volume on mac and linux and the data was intact (naturally, since it was an issue with teh usb port, not the actual drive itself). I was relieved and took the drive home, ready to get back to work.

    When I plugged it in, my computer gave me the dreaded "This Disk Can Not be Recognized by this computer (initialize/ignore/eject)" I quickly ignored the problem and opened disk utilities, where I got the following information:

    Disk Description : WDC WD10 EADS-11M2B2 Media
    Total Capacity : 931.5 GB (1,000,204,886,016 Bytes)
    Connection Bus : USB
    Write Status : Read/Write
    Connection Type : External
    S.M.A.R.T. Status : Not Supported
    USB Serial Number : WDC WD10EA WD-WCAV57559890
    Partition Map Scheme : Unformatted

    What the HELL is going on? It worked at the store on Mac and Linux, I take it on a short ten minute drive home, plug it in and BAM, it doesn't work.

    Reformatting and erasing this data just isn't an option. I'm a wedding photographer and I back up my data every night. HOWEVER, on Sunday night, the backup failed. My wedding from Sunday is trapped on this drive and it's not an option to reshoot it. At this point I will pay any amount of money to recover the data...I don't even care about the drive...I just want my damn pictures.

    Any insight from people with more expertise than I? I haven't touched the drive except to look at the info tab in disk utility. Other than that, nothing. It hasn't ever successfully mounted to my computer from the second I brought it home.

    It's now sitting forlornly in the box; I'm afraid to touch it :(

    I should also mention, this guy was a very reputable company...I did my research. 30 years experience, tons of referrals, BBB Preferred status, awards from the local paper for being the best repair store in town, etc etc etc.
     
  2. iBookG4user macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
    #2
    Have you tried connecting the external hard drive to a different Mac?
     
  3. katedorsey thread starter macrumors newbie

    Joined:
    Jul 14, 2010
    #3
    Yes...I work off of another mac for my day job that's running 10.5.8 vs. my 10.6.4 at home. Still no dice. A coworker had a start up disk that we ran with disk warrior and some other fun stuff on it.

    The weird thing is...in the graphical representation of the computer, the hard drive shows up next to the start up disk and the internal drive. BUT...when we went to select it from the drop down menu to repair it...it's not there. I know it exists because the computer recognizes it, but it's definitely not showing up as an option to repair.

    It spins just fine, also.
     

Share This Page