Mystery part!!! & headphone jack problem !

nomana

macrumors newbie
Original poster
Jan 6, 2012
5
0
Hi,

I replaced my middle frame of my white iphone4 and when I tried to reassembled it, one small part fell from nowhere.

I have no idea what it is. I looked up in the ifixit but no luck.

however, i reassembled my phone without it and everything works except headphone remote.

Headphone has sound but there is noise and distort feedback during the jack plugging ing and out which never happen before.

Moreover, the remote on headphone is not working too.

I am not sure if small part and headphone problem are related or maybe there are 2 different things.

Here are the pictures of the part I mentioned:
Thank you
 

Attachments

MacBookPr0

macrumors regular
Feb 5, 2011
130
0
I know exactly what that is,

The emi shielding that is over the display connectors has that on what is the top screw and I believe is some ground it will fit right in the top notch

if you need more clarifaction just ask and ill be glad to take a pick of where its in in my phone
 

nomana

macrumors newbie
Original poster
Jan 6, 2012
5
0
I know exactly what that is,

The emi shielding that is over the display connectors has that on what is the top screw and I believe is some ground it will fit right in the top notch

if you need more clarifaction just ask and ill be glad to take a pick of where its in in my phone
wow, thank you so much.

I really want to know where it supposes to be.

PS. you have any idea about the headphone jack problem?

Cheers
 

MacBookPr0

macrumors regular
Feb 5, 2011
130
0
wow, thank you so much.

I really want to know where it supposes to be.

PS. you have any idea about the headphone jack problem?

Cheers
i don't know but maybe check the connections on the motherboard, and try to reconnect this part