Mystery part!!! & headphone jack problem !

Discussion in 'iPhone Tips, Help and Troubleshooting' started by nomana, Jan 6, 2012.

  1. nomana macrumors newbie

    Joined:
    Jan 6, 2012
    #1
    Hi,

    I replaced my middle frame of my white iphone4 and when I tried to reassembled it, one small part fell from nowhere.

    I have no idea what it is. I looked up in the ifixit but no luck.

    however, i reassembled my phone without it and everything works except headphone remote.

    Headphone has sound but there is noise and distort feedback during the jack plugging ing and out which never happen before.

    Moreover, the remote on headphone is not working too.

    I am not sure if small part and headphone problem are related or maybe there are 2 different things.

    Here are the pictures of the part I mentioned:
    Thank you
     

    Attached Files:

  2. MacBookPr0 macrumors regular

    Joined:
    Feb 5, 2011
    #2
    I know exactly what that is,

    The emi shielding that is over the display connectors has that on what is the top screw and I believe is some ground it will fit right in the top notch

    if you need more clarifaction just ask and ill be glad to take a pick of where its in in my phone
     
  3. nomana thread starter macrumors newbie

    Joined:
    Jan 6, 2012
    #3
    wow, thank you so much.

    I really want to know where it supposes to be.

    PS. you have any idea about the headphone jack problem?

    Cheers
     
  4. MacBookPr0 macrumors regular

    Joined:
    Feb 5, 2011
    #4
    i don't know but maybe check the connections on the motherboard, and try to reconnect this part
     
  5. jpetticrew macrumors 6502a

    jpetticrew

    Joined:
    May 13, 2009
    Location:
    Texas
    #5
    That fell out of my phone too. After that my wifi and bluetooth range was absolutely awful...
     
  6. nomana thread starter macrumors newbie

    Joined:
    Jan 6, 2012
    #6
    I just noticed that my wifi signal is not normal aswell.
     

Share This Page