MyWi doesn't allow Internet connection on computers

Discussion in 'Jailbreaks and iOS Hacks' started by mojoe24, Jan 3, 2010.

  1. mojoe24 macrumors regular

    Joined:
    Dec 1, 2009
    #1
    Has anyone ran into this problem? I set MyWi and my computer connects to the phone through wifi, but the computer doesn't get internet connection. All the pages do not load up.
     
  2. SpaceKitty macrumors 68040

    SpaceKitty

    Joined:
    Nov 9, 2008
    Location:
    Fort Collins Colorado
    #2
    Does your iPhone show a blue bar at the top that shows that it is tethering? If not than your MyWi is not working and so your computer won't work either.

    My iPhone does this sometimes and all I have to do is reset network settings and then my MyWi works again.
     
  3. mojoe24 thread starter macrumors regular

    Joined:
    Dec 1, 2009
  4. maxim.iphone macrumors newbie

    Joined:
    Feb 1, 2010
    #4
    There are a number of reasons that it may not work.

    1. MyWi is a paid up and only comes with a 10-day or 14-day trial before it will no longer work as a tethering tool.

    2. MyWi works more reliably for the latest 3.1.2 firmware. MyWi will still function, but with limitations for 3.0 firmware. It will not function with earlier firmware versions. To check your firmware, go to Settings-> General-> About and you'll be able to find the version [i.e. 3.1.2 (7D11)].

    3. MyWi has had known issues working with unlocked phones using other network data services. AT&T, technically, does not provide the data services for the iPhone, only the data plan. Apple provides the data services. As an example, if you were to unlock your iPhone to be used with T-Mobile (USA), the data plan for T-Mobile uses T-Moby (may be named differently) Services for data usage. This service may be incompatible as a mainstream HTML browsing platform for MyWi.

    4. MyWi does not work with 1st Generation iPhones and iPods. 2nd Generation devices still suffer hardware restraints for tethering. 3rd Generation 3G and 3GS are preferred for the use of MyWi.

    5. MyWi is still susceptible to human error as is any Jailbroken application. MyWi uses not just WiFi technology, but wireless network data transfer technology. MyWi turns your device into a mobile HotSpot similiar to the deivce sold by Sprint. That means that MyWi has a Wireless SID name (one that you name manually) and can also have a WEP password (one that you can set) like any normal wireless network. If you cannot connect to the internet on your laptop, you probably neglected to enter the WEP password when connecting to MyWi. Try connecting to the internet on you laptop with WEP on MyWi disabled.

    6. Lastly, if all else fails, it may be the way in which you Jailbroke your phone. Most of us using 3.1.2 used Blackra1n which conveniently aided in enabling the tethering capability. Most Jailbreaking softwares do that, but some don't. I currently know of no way to enable it, but Cydia, RockApp, or Icy may have something for you.


    Reminder, MyWi is a paid product through RockApp. To use RockApp, you must register. More importantly, registering with RockApp automatically saves all installed jailbreak apps and extensions for backup use. No more need to search for them all again. Enjoy!
     
  5. Bl0ckHe1d macrumors 6502

    Bl0ckHe1d

    Joined:
    Nov 19, 2009
    Location:
    Caledonia
    #5
    try disabling the current network (i.e. company network or home network)

    i've noticed that i cannot access a particular website due to the company firewall unless i disable the company network!!
     
  6. mmayo2112 macrumors newbie

    Joined:
    Aug 6, 2010
    #6
    MyWi cannot connect to Windows 7 - FIXED FOR ME:

    From the laptop that you are trying to connect to, these are the important settings:

    Goto your device manager and right click on your wireless network adapter and choose properties, then goto advanced tab. You may have several properties on that tab, two of them are important.

    One is the 'wireless mode selection.' It is likely set to auto - try 802.11b/g instead of the 'auto' that it may be on. I think this is mandatory.

    Two is the AdHoc 11n - this needs to be enabled. I'm not sure why you need to enable 11n when we're telling the adapter to use wireless g - I asked two MCTS's, an MCSE and a CCVP - noone seemed to know why. But it did work for me.

    Now, doing this SHOULD allow you avoid the "Windows was unable to connect to IPhone MyWi error; at the least you should be able to connect to it. NOW, you may need to go to Start|Run|cmd (enter) and type: ipconfig /renew or ipconfig /release then ipconfig /renew to get a valid IP, but I've just seen it work on Windows 7 32 and 64 bit, AND my windows server 2008 R2 with Hyper-V enabled, so it should also work for you.

    FINALLY a reason to value my unlimited data plan I was grandfathered into...
     
  7. mevsmywi macrumors newbie

    Joined:
    Aug 15, 2010
    #7
    mywi with windows 7; wont load web pages

    i am able to download torrents in utorrent and connect to servers for games while connected to mywi but when i try to browse the internet, it says im not connected. i ran a diagnostic and it failed the ping test, saying "invalid test in adhoc mode". been messing with it for a while and any help would be appreciated. running mywi on jailbroken 3gs 3.1.2
     
  8. chargit macrumors 6502a

    chargit

    Joined:
    Jan 17, 2010
    Location:
    Evansville, In
    #8
    never mind on the edit...I looked at the wrong catagory so I deleted it. very thankful on this info I really hope it works!
     
  9. nyyanks macrumors newbie

    Joined:
    Jun 28, 2009
    #9
    Thanks so much for your help. I tried a few times but I finally got Mywi to work with my laptop running 64bit Windows 7. Although I didnt have the exact same settings for my wireless adapter, I found settings that seemed the same to what you had described. Connected instantly. Thanks
     
  10. adwivedi macrumors newbie

    Joined:
    Nov 11, 2010
    #10
    Hi There-

    I am running into the same problem on my Dell Latitude running Win 7 64 Bit.

    It detects the wireless ID, I click on it - Enter the Wep Key but then it just keeps trying to connect. Finally fails.
    I made sure as suggested above that the network card is set to 802.11b/g and AdHoc 802.11n is enabled. Still no luck.
     
  11. volcom883 macrumors regular

    volcom883

    Joined:
    Sep 29, 2008
    Location:
    istanbul
  12. sandeep9669 macrumors newbie

    Joined:
    Mar 9, 2013
    Location:
    India
    #12
    This worked for me.
    Thanks.
     

Share This Page