MyWi help

Discussion in 'iPad Hacks' started by shady825, May 10, 2010.

  1. shady825 macrumors 68000

    shady825

    Joined:
    Oct 8, 2008
    Location:
    Area 51
    #1
    Jailbroke my phone over the weekend and installed MyWi.
    It worked at first but now it seems hit or miss..

    A few things im not clear on:
    -Do I turn wifi on first in the phone settings?
    -Do I need to turn on "Internet Tethering" in settings as well?

    When I try to connect my iPad it says im on the network I created but safari wont load any pages.

    Thanks for the help and sorry if Im missing something really simple.. I feel like I am since MyWi seems to be working fine for everyone else.

    Details: iPhone 3G on 3.1.3, jailbroken with Spirit, MyWi with Rock (am still on trial. I'd like to purchase it if I can get it working 100%)
     
  2. Kawjumper201 macrumors member

    Joined:
    Apr 15, 2010
    #2
    I don't know if this is your problem or not but I am using the "no rock" paid for version and I have had no problems. I'm using 3.1.2 tho.
     
  3. lavrishevo macrumors 68000

    lavrishevo

    Joined:
    Jan 9, 2007
    Location:
    NJ
    #3
    Yes, wifi does need to be on.

    Yes, tethering should be on before you start mywi.

    If your purchase it make sure your license gets installed correctly then uninstall Rock via cydia, this will also uninstall mywi BUT you can turn around and install wywi (no rock) right afterwards. The reason want to do this is because Cydia and Rock don't play nice with each other. Every once in a while you may need to reset your network settings to clear things out.
     
  4. MikePA macrumors 68020

    MikePA

    Joined:
    Aug 17, 2008
    #4
    Not true.
     
  5. lavrishevo macrumors 68000

    lavrishevo

    Joined:
    Jan 9, 2007
    Location:
    NJ
    #5
    May not be the case for you but it is the case for many, including myself. The number of incidents of Rock screwing up peoples phones is much higher then Cydia.
     
  6. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #6
    My husband has MyWi (no rock) and I've been wanting to buy it myself but have been waiting for Appsidy to be up and running to purchase it. Now it says it won't ever be happening and to wait for it to appear in Cydia store.

    Does anyone have a clue/inside knowledge on about when that might happen?
    Conversely, is there a good way to install the Rock version and then 1000% thoroughly clear it out as if it never happened? TIA
     
  7. lavrishevo macrumors 68000

    lavrishevo

    Joined:
    Jan 9, 2007
    Location:
    NJ
    #7

    Nothing in the jailbreak world is 100% let alone 1000%. You can wait till it comes to Cydia or just install Rock, purchase and install Mywi, delete Rock through Cydia as mentioned before and install Mywi (no rock). This setup seems to work good and is more reliable. Just keep your info backed up as much as possible via iTunes and you will be fine. With the nearly 3 years I have had jailbroken phones I have had to restore the phone only a few times based off of jailbreak related failures.
     
  8. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #8
    Well, I did the above and when trying to remove rock, got a 'reload springboard' screen which stayed that way for 20 minutes. Now I'm stuck at the apple logo.

    I should've stayed away from Rock. Apparently this is an issue with it. I'm facing a restore :(

    EDIT: It took a while but I managed to get up and running with Rock cleared out (via SSH)
     
  9. HXGuy macrumors 68000

    Joined:
    Mar 25, 2010
    #9
    So MyWi (No Rock) is no longer available if you do a search on Cydia? That's how I got it.
     
  10. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #10
    No. Not for purchase. Expecting it to come to the Cydia store soon but who knows when.
     
  11. HXGuy macrumors 68000

    Joined:
    Mar 25, 2010
    #11
    But it was there at one time right? I mean I got it for my iPhone and iPad by searching on Cydia for it...it found both the Rock and No Rock versions and I got the No Rock for $9.99.
     
  12. MikePA macrumors 68020

    MikePA

    Joined:
    Aug 17, 2008
    #12
    The only problem I have had with MyWi is the DHCP portion of it.

    The first time I start MyWi, it works fine.

    The second time, it starts, shows the blue bar at the top of the screen, devices can see it but they can't get an IP address. They show the 169... IP address which indicates this.

    I reboot my iPhone, start MyWi and all is well.
     
  13. jongriff macrumors regular

    jongriff

    Joined:
    May 28, 2003
    Location:
    Ipswich
    #13
    Sounds very similar to my problem. Are you running with WEP enabled? If so try disabling it and then rebooting your iPhone
     
  14. jjordanov macrumors newbie

    Joined:
    May 26, 2010
    #14
    What was that you did using SSH? I am stuck at the same place - apple logo after installing MyWi and Rock, reboot and delete MyWi and Rock from Applications. Still accessible through SSH though.

    Please help... :(
     
  15. meagain macrumors 68030

    Joined:
    Nov 18, 2006
    #15
    I had to keep rebooting and retrying things to get in there then I ssh'd in and deleted rock from applications. Seems deleting it from Cydia caused all kinds of problems for me.
     
  16. dquajae macrumors newbie

    Joined:
    Aug 5, 2010
    #16
    I tried loading MyWi using Cydia on my Ipad and I'm stuck with Apple Logo. What can I do to fix this? Thanks
     

Share This Page