Mywi on iPhone 4 with Jailbreakme

Discussion in 'Jailbreaks and iOS Hacks' started by seungmook.lee, Aug 1, 2010.

  1. seungmook.lee macrumors newbie

    Aug 6, 2008
    I just jailbroke my iPhone 4 using the web-based jailbreakme and tried to download Mywi 4.0, but it keeps saying "size mismatch" and failed to download..

    does anybody successfully install Mywi on iPhone 4?
  2. phatjoe88 macrumors member

    Jun 18, 2010
    I installed it without a problem from Rock.
  3. aelalfy macrumors 6502a

    May 2, 2010
    Berlin, Germany
    I had that same problem after jailbreaking. What I did was restart holding the home+ power button for 10 seconds then tried again and it worked.

  4. moussekateer macrumors 6502a


    May 12, 2009
    Any error you get downloading stuff in Cydia or RYP is because of the huge load they're under now. Keep trying or have a break and try again later.
  5. Clete2 macrumors 65816


    Sep 20, 2008
    I'm going to say that it's because modmyi is under heavy load now. Wait a while and you'll get it. It took me about 45 minutes to get modmyi to respond.
  6. seungmook.lee thread starter macrumors newbie

    Aug 6, 2008
    Thanks for all posting, I got now Mywi and tether to iPad! yeah!
  7. xMastemah macrumors member

    Dec 6, 2009
    Same reason Cydia's reload time is like 30 seconds just to display the front page. :S
  8. spencers macrumors 68020


    Sep 20, 2004
    ModMyI must be down because downloading MyWi keeps failing on me.
  9. kuhroo25 macrumors member

    Aug 2, 2010
    So does wifi tethering (via MyWi 4.0) in fact work with an iPhone 4 on iOS 4.0.1? I had read that only USB tethering was working, and I really only want it to tether to my iPad. Thanks in advance.
  10. ciparis macrumors newbie

    Jul 22, 2002
    Rock crashes on launch for me. I can't find MyWi on Cydia at all.

    iPhone 4, fresh restore before jailbreaking via

    Edit: found it. Had to add as a source. Servers are getting smashed at the moment though so it may be awhile before it's downloadable again ;p still waiting...
  11. koilvr macrumors 6502


    Jun 15, 2010
    Knoxville, TN
    Took me about 5 tries till I got it, works fine.
  12. daboltz macrumors member

    Jul 23, 2010
    are you using MyWi 4.0?
  13. Nshon macrumors newbie

    Aug 6, 2010
    Ok I can confirm that MyWi works wih iPhone4 jb'd through Here's briefly what I did.

    Went direct to - got stuck on purple screen. Followed instructions on here and got it working.

    Cydia then warns about some necessary upgrade and presented a screen about some unsafe upgrade which I ignored and updated anyway.

    Searched for rockapp in Cydia. Installed rock. Found MyWi in Rock, installed, reboot and now wifi tethering through iPhone4 with iPad works!

    YMMV. It worked for me.

Share This Page