Mywi wifi tethering not working

Discussion in 'Jailbreaks and iOS Hacks' started by riveting, Nov 30, 2011.

  1. riveting macrumors 6502

    Joined:
    Mar 11, 2009
    #1
    I just spend $20 and bought the Mywi license from Cydia, and the Wifi tethering is not working. Every time I turned it on, it will wait for a while, then shows "Cleaning off Mywi, please wait....", then it turned off itself. Any one experience similar problem? this is on an iphone 3gs with tethered jailbroken iOS 5.0.1. The USB tethering works fine.
    :eek:
     
  2. Viapple macrumors newbie

    Joined:
    Dec 1, 2011
    Location:
    Northern Virginia
    #2
    MyWi connects to Mac laptops, but no Internet connectivity

    I, too, have recently noticed that MyWi will not allow me to connect to the Internet from any of our Mac computers. Two are recently upgraded to OS Lion and I suspected that to somehow be the issue, but I was also unable to connect using an older MBP running Snow Leopard. HOWEVER, I can successfully access the Internet with MyWi from my iPad.

    The MyWi app has performed flawlessly from day one until recently. In fact, it's the only, or at least the principle, reason I performed the JB in the first place. Very disappointed after also sending an email to the developer and receiving no assistance. In fact, there's been no reply whatsoever.

    Here are the details:

    -Pings from my MBPs to the iPhone 4 running MyWi time out.
    -All MBPs show an active connex to MyWi in the menu bar Airport icon.
    -Pressing the Option key while clicking on the Airport menu bar icon reveals active connex, data rate of 54, active BSSID, etc. So it is a solid connex.
    -System Preferences>Network>Advanced>DNS includes the iPhone's MyWi IP address (as a just in case).
    -Firefox, Chrome, Safari browsers cannot connect to any web site.
    -Console log shows an active connection to the iPhone.
    -MyWi performed flawlessly for months from these very same machines until yesterday (11/30/11). Nothing significant about that date except for the fact its the second time I've attempted to connect to the Internet using MyWi. First noticed it not working over two weeks ago, but was in a rush and just figured I mis-configured something...which is hard to do.
    -Macs are running OS X Lion 10.7.2 and 10.6.8
    -MyWi license was purchased months ago; upon noticing that MyWi had advanced to the latest v5.0, I have initiated the three-day trial and it is currently active. Not a MyWi licensing issue because it did work today using the iPad.
    -The MyWi problem seems to be specific to Mac laptops (perhaps Windows as well)

    Lastly, if anyone has experienced these same problems, please reply to my post including which operating systems you're running, when you started having issues with MyWi, and please offer some educated opinions as to what might be going on.

    Regards,

    Viapple
     
  3. markoffate macrumors newbie

    Joined:
    Jan 31, 2011
    #3
    OnDemand not working

    Replaced my iPad recently (still original model) and can no longer get Ondemand to work, iPhone 4 running iOS 4.3.2 to iPad running iOS 5.0.1. Tried re-installing MyWi on both devices, resetting, etc. - no joy. Just can't get the devices to pair the Ondemand connection. IPad detects iPhone hotspot but cannot establish a connection. Anyone else having that problem?
     
  4. idungku macrumors newbie

    Joined:
    Jan 2, 2012
    #4
    i dont know if this is the same issue, but after i upgrade to snow leopard MyWi 4 can't connect to the internet. its connected to my mac but dont have any internet connection. i use the "assist me" on system preference>network and just follow the procedure given and now i can connect to the internet like i used to. the problem seems to be on the DNS setting.
    hope it help
     
  5. Tensakun macrumors 6502

    Tensakun

    Joined:
    Jan 21, 2008
    Location:
    Akashi, Japan
    #5
    me too

    I've had the exact prob since moving up to 5.01 via both Pwnage tool and Redsnow (stupidly guessed the first JB didn't take). Like other poster, it's the only reason I really JB. Any solution? Or go to another tethering app?:confused:
     
  6. rubasu macrumors newbie

    Joined:
    Feb 29, 2012
    #6
    There is a possible FIX!

    I know I am a bit too late in this thread but I was having the same exact problem on my 3GS iOS 5.0.1, I would start up MyWi and it would try to tether and then say "Cleaning Up" and my wifi wouldn't work at all after that.

    I found a way to get it working, its a strange workaround but it works.

    What I did is, restarted the phone, once I got back into springboard, I went into settings and Enabled personal hotspot in the iOS.

    Then tried turning on Wifi tethering in MyWi and it mysteriously started to work. I am not sure if this will work for everyone but it works for me.

    Hope that helped!
     

Share This Page