Discussion in 'Jailbreaks and iOS Hacks' started by thundermustard, May 25, 2010.

  1. thundermustard macrumors regular

    Apr 21, 2008
    OK, I have been working on this issue forever.
    I can only get my MacBook to use MyWi with the USB cable. If I make the hotspot it just won't connect to the Internet.
    Yesterday I was at Best Buy and used my iPhone to tether a display iPad using my MyWi. Now I know that MyWi is working it is the Mac that is the problem.
    I also noticed that the iPad connects like it is a normal wifi network while the MacBook shows it as a device rather than a network and when it connects it goes from the wireless icon on the MacBook to the ad hoc connection. Is that normal?
    What can I do on the MacBook end to get this damn thing working?
  2. dhlizard macrumors G4


    Mar 16, 2009
    The Jailbreak Community
    Shows up as a device on my MacBook

    Attached Files:

  3. thundermustard thread starter macrumors regular

    Apr 21, 2008
    So what could possibly be keeping my MacBook from using the hotspot function while it worked on the iPad. Remember, this is on two different MacBooks.
  4. thundermustard thread starter macrumors regular

    Apr 21, 2008
    Still trying to work this issue out. MyWi works as a wifi hotspot with my XP netbook but not with my MacBook.
    I have to use a USB cable to get the MacBook to work. Any ideas?
  5. smh macrumors newbie

    Jan 28, 2011
    Any news!?

    Hey, I just tried to connect my friends' macbook to the mywi hotspot and had the same issue as you described. I've been scouring the internet for an explanation and/or work around and have come up blank. Just wondering if you ever found a solution... much thanks in advance.
  6. terpolymer macrumors newbie

    Aug 17, 2011
    Same here

    I'm having the same problem... WiFi works fine on my iPad and PC, but not on my MacBook.

    Any ideas?
  7. polobreaka macrumors 6502a

    Aug 10, 2009
    Huntington Beach, CA
    i dont have my mbp with me at the moment but i think you have to go into your network settings (preference/network) and enable something. maybe internet sharing? i dont remember.
  8. kronrenovations macrumors newbie

    Apr 21, 2013
    This is how I got my 2012 MBpro to work.

    On MBpro:
    System prefs>Network>Wifi>Advanced>TCP/IP tab>Use DCHP
    You cannot use any form of manual ip (DHCP only)

    In Mywi:
    Under WIFI HotSpot tab, Security must be set to "None".

    For hours I have been trying all sorts of combinations and this has been the ONLY way I can get somewhat stable performance.

Share This Page