NAS and USB Connectivity issues with iMac

Discussion in 'iMac' started by AussieCol, Nov 25, 2010.

  1. AussieCol macrumors newbie

    Joined:
    Sep 14, 2010
    #1
    Recently treated myself to a mid-2010 27" i7 iMac to get me away from the clutches of Mr Gates. I also bought a Seagate BlackArmor 2TB NAS as extra storage and a Samsung "Story" 1.5 TB external USB HDD for backups using my program of choice "Memeo". I tried Time Machine but it could not "see" my NAS, which is why I bought the external USB drive, and it does not do real-time automatic incremental backups like Memeo. Sadly the iMac keeps randomly dropping connections to both drives and is putting my storage/backups in jeopardy. Writing and copying files to the NAS is very slow - when it is actually talking to the Mac. They both work perfectly with my HP Workstation when formatted in NTFS, but re-formatting in Mac file system doesn't help them stay connected my shiny new iMac. I have seen in other forums that other iMac users have had similar experiences with various NAS boxes and USB drives. Other than complaints that Apple need to fix this, I can find no solution. As a non-geek can anyone give me any simple clues on how I might get my hardware working and ensure some solid backups on it?
     
  2. dj2mc macrumors member

    dj2mc

    Joined:
    Nov 24, 2010
    Location:
    Ottawa, ON [CAN]
    #2
    I would try partitioning the NAS drives, etc. Leave half for Mac OSX Extended (journaled), and the other NTFS for Windows? *Do this directly plugged in and not over the network*
    Then your Time Machine will read the OSX partition, and then your HP can access the Windows side. Seems to me that it doesn't know what to do with the file format of the drive.
    Anyone else want to chime in to confirm?
     
  3. AussieCol thread starter macrumors newbie

    Joined:
    Sep 14, 2010
    #3
    Thanks for the reply. I don't want to use it on my PC (soon to be on eBay if I can get this fixed - otherwise bye, bye, Apple) but I just connected it temporarily to make sure the drives were OK. Why should the iMac suddenly disconnect the USB drive? It is connected directly to the back of the unit. Even tried through a powered hub but same story. The 8-port Gigabit ethernet switch is also functioning with everything else on my LAN but the iMac communicates for a while, then drops it.. I'm at a loss for ideas. Hope someone can help as I want to stick with Apple.
     

Share This Page