NAS drive and Airport Express

Discussion in 'Mac OS X Server, Xserve, and Networking' started by avaria, Jan 25, 2009.

  1. avaria macrumors newbie

    Joined:
    Jan 25, 2009
    #1
    I am trying to connect to my NAS drive through an Airport Express. The drive is an Iomega StorCenter 1TB NAS drive, and it is connected with an ethernet cable to a Netgear 5-port network hub. The Airport Express is also connected to the network hub by an ethernet cable. I can connect to the drive when it is plugged in directly into the MacBook ethernet port. I usually connect to it using either Safari/Bonjour or Finder>Go>Connect to Server using afp. I can never connect to the drive through the wireless network--it is not showing up on the network. I am guessing I need to change the Airport Express setup somehow, but I do not know where to start.

    Eventually, I would like to back up to the drive using Carbon Copy Cloner, but for starters I'd be happy just to be able to connect to the drive. I use Mac OS X 10.5.6.
     
  2. pyrodex macrumors 6502

    pyrodex

    Joined:
    Jul 10, 2008
    Location:
    Atlanta, GA
    #2
    The Airport EXPRESS does not support an AirDisk like the EXTREME does. The USB port on the EXPRESS only supports Printers.
     
  3. avaria thread starter macrumors newbie

    Joined:
    Jan 25, 2009
    #3
    pyrodex: thanks--I know it doesn't *directly* support NAS drives, and I am not trying to plug it into the USB port. I described the setup above: AirPort Express and the NAS drive both plugged into a third-party network hub. Now, is there a way to configure this setup so the NAS drive is visible on the Wi-Fi network?
     
  4. theBB macrumors 68020

    theBB

    Joined:
    Jan 3, 2006
    #4
    Yes. One possible way is to find out IP address of the NAS device when you are still on the ethernet network. Sometimes if you use Finder Connect for that IP address, it works properly even if Mac does not find it automatically.

    The second, more proper way is to set AE so that it does not distribute IP addresses. (It just forwards the IP addresses assigned by your router to your WiFi network users.) Then it effectively becomes one big network even though some of it spans WiFi. I am not at home right now, but I think you should be able to access such a checkmark in DHCP tab or something similar to that via Airport Admin Utility.
     
  5. jaw04005 macrumors 601

    jaw04005

    Joined:
    Aug 19, 2003
    Location:
    AR
    #5
    Here you go:

    Change "Connection Sharing" to "Off (Bridge Mode)" in the Internet settings pane.
     

    Attached Files:

  6. avaria thread starter macrumors newbie

    Joined:
    Jan 25, 2009
    #6
    jaw04005--I actually tried that before starting the thread, but it didn't work. When I set AirPort to bridge mode, the MacBook cannot connect to the internet (no IP address!) OR the NAS drive.

    By the way, my window looks different from yours. I do not have a "Renew DHCP lease" button in AirPort Utility (it appears only in Network Preferences).
     
  7. theBB macrumors 68020

    theBB

    Joined:
    Jan 3, 2006
    #7
    Here is how mine looks like:

    If you unclick that button on the top that says "Distribute IP addresses", then your WiFi and ethernet networks will look as one.
     

    Attached Files:

Share This Page