NAS File Permissions - Access Denied in Windows XP

Discussion in 'iMac' started by layziegtp, Nov 30, 2009.

  1. layziegtp macrumors regular

    Joined:
    Oct 26, 2009
    #1
    (I originally posted this on the Apple discussion forums, but it's been two days with no replies!)

    Alright, I'm going to explain what I did, and hope that somebody here can tell me what I did wrong, or how to fix this...

    New iMac arrived. Transferred all the files from my NAS (Iomega StorCenter 1TB) to my iMacs hard drive. Formatted the NAS. From the NAS web interface, I created two users, admin (passworded, read+write) & user (no pw, read only). Also created one shared folder, Data, privelages showed up correctly as I had set them for the two users. From the iMac, I transferred the files back to Data. 10 hours later, I check from the iMac, files are there, user privelages work properly, data is intact, all set.

    Fast forward one day. I installed XP SP3 with Boot Camp. From XP, I open \\NAS\Data. Login with admin + password. My two subfolders are there, along with a couple Mac hidden folders (Trash, and something else). I try to open the subfolder Games. Access Denied - You do not have proper privelages to view the contents of this folder. Hmm? Same thing with the second subfolder.

    I've tried changing pretty much everything I can think of. I ensured that my NAS privelages were set up properly from the web interface. Thinking that the Mac may have set some of it's own permission on the files/folders, I checked that. They show one user, 'Everyone', and it's permissions are set to No Access. I tried to change it for all the subfolders to Read&Write, but as soon as I leave the Info window and come back, it's reset to No Access. Still I can access the data just fine from the Mac.

    .
    TLDR - My NAS data is accessable from my Mac, but not from Windows, even using the same login credentials. Help!

    I'm not sure what I did, but now I can't even open the folders in Mac! The folders show little red minus signs and tell me I don't have permission to view their contents.

    All I want is to get my data back! Halp!
     
  2. layziegtp thread starter macrumors regular

    Joined:
    Oct 26, 2009
    #2
    On the iMac, if I connect using afp://192.168.1.1, I see the two folders, with little red minus signs, and I get an error saying I don't have permission to open either of them. If I connect using cifs://192.168.1.1, I can see the two folders, and open them, but they appear empty.
     
  3. layziegtp thread starter macrumors regular

    Joined:
    Oct 26, 2009
    #3
    One last bump, only out of desperation. I'm afraid I've lost 250GB worth of data. It's right there, I just can't access it...

    I would take the drives out of the NAS and put them in a desktop, but they are set up in a striped RAID configuration, and I'm not sure if I can even do that.
     
  4. RandomKamikaze macrumors 6502a

    RandomKamikaze

    Joined:
    Jan 8, 2009
    Location:
    UK
    #4
    A) You are not allowed to bump your own threads, its against the rules
    B) You might wanna leave it a little bit longer between bumps as you haven't left it very long


    With regards to your problem its permissions. You've said that only the 'Everyone' group is listed meaning everyone else is implicitly denied. You need to modify the permissions to allow your user account Read & Write. This can be done by clicking the '+' button
     
  5. pokrface macrumors member

    Joined:
    Dec 14, 2007
    #5
    Effective permissions for a security principal on an object are always least-permissive. If the Everyone group is set to "No Access", then that's exactly what it means--no one has access to the file, not even the administrator. You're not having any luck changing the permissions at this point because, surprise, the Everyone group is set to "No Access" and so no one has access to change the permissions.

    The way around this on Windows is to log onto the system with an administrative account and take ownership of the files and directories in question. You can Google for the procedure--system administrators always have that as an ultimate out to prevent them being denied access to data on a system they control. The way around this on a system that uses POSIX permission bits is to log on as root and chmod the files and directories so they're readable to others (755 is a good one to try).

    Your problem, obviously, is that you're not just dealing with file permissions--the NAS is imposing share permissions as well, and share + file permissions stack, which can make figuring out an object's effective permissions difficult. Verify that you haven't imposed any unnecessary share permission restrictions via the NAS--for CIFS/SMB, set the share so that Everyone has Full Control. For NFS, make sure that every computer you want to access the NAS is in every one of the export groups (root, read/write, access hosts, and whatever else you have).
     

Share This Page