Nasty sounding freezes

Discussion in 'Mac Pro' started by big_malk, Feb 14, 2009.

  1. big_malk macrumors 6502a

    Joined:
    Aug 7, 2005
    Location:
    Scotland
    #1
    My Mac Pro has a tendency to freeze up now and then for a few seconds at a time, for no apparent reason.

    When it does this, iTunes seems to replay the last half second or so of whatever is playing, and it builds up getting louder and louder. Nothing on screen moves, no response form the mouse or keyboard. Then, after a few seconds, it just carries on like normal.

    I used to have an X1900 graphics card, which overheated and cause weird graphic anomalies, and I thought it was causing these hangs, but a while ago I replaced it with an 8800GT and I dust it regularly (just last week), but it still happens sometimes (today, for a particularly long time).

    Any idea what could cause this and how to prevent it?
     
  2. bartelby macrumors Core

    Joined:
    Jun 16, 2004
  3. big_malk thread starter macrumors 6502a

    Joined:
    Aug 7, 2005
    Location:
    Scotland
    #3
    :eek: I hope not! I've lost loads of stuff of stuff a couple of times because of that happening on my PowerBook a few years ago. Time machine will protect me this time!

    The S.M.A.R.T. status of all my HDs is 'Verified', but I have heard that SMART isn't the most reliable toll for knowing if a drive is failing?
     
  4. drewsof07 macrumors 68000

    drewsof07

    Joined:
    Oct 30, 2006
    Location:
    Ohio
    #4
    Just in iTunes, or does this happen with other apps as well?

    If so, then I'm going to agree with bartleby and say something's wrong with your HD.

    If it is only in itunes, I would say you have some corrupt files. Back up your music, delete itunes and the preferences com.apple.itunes, reinstall the app from scratch and see if that helps?
     
  5. big_malk thread starter macrumors 6502a

    Joined:
    Aug 7, 2005
    Location:
    Scotland
    #5
    It happens no matter what I'm doing, although I almost always have iTunes open. Dreamweaver 9 hangs for a few seconds quite often, but that seems to just be a Dreamweaver issue, nothing else is affected. iTunes is just a very noticeable symptom of the hang because of the way it makes the horrible noise.

    How would reinstalling iTunes from scratch effect my playlists and play counts? Now I think about it, there is a song that iTunes regularly says its analysing the volume of when it opens, and there's song (can't remember if its the same one) than updates on my iPhone almost every time I sync it, even though it never changes and I don't think I've ever once played it. Hopefully it is just a corrupt file, but that should freeze my whole system should it?

    Are there any tools that could test my hard drive more in-depth than Disk UtilityS.M.A.R.T. status?
     
  6. djjclark macrumors regular

    Joined:
    Feb 17, 2008
    #6
    you see any weird messages in your console that might correlate?
     
  7. big_malk thread starter macrumors 6502a

    Joined:
    Aug 7, 2005
    Location:
    Scotland
    #7
    Any idea what I might be looking for?
    I'll have a look next time it happens, but I wouldn't know where to start looking right now :confused:
     
  8. big_malk thread starter macrumors 6502a

    Joined:
    Aug 7, 2005
    Location:
    Scotland
    #8
    I've been keeping an eye on the console whenever theres a hang (none from iTunes today) but here a few that caught my eye...

    18/02/2009 11:34:56 kernel unknown SIGSEGV code 0
    -That seems to happen twice, every 20 seconds

    18/02/2009 11:34:43 /Applications/Adobe Dreamweaver CS4/Adobe Dreamweaver CS4.app/Contents/MacOS/Dreamweaver[343] Allocator race detected: transaction is not verified for -104/2 - Websites/Website/_notes/dwsync.xml

    18/02/2009 11:04:16 /Applications/Adobe Dreamweaver CS4/Adobe Dreamweaver CS4.app/Contents/MacOS/Dreamweaver[343] Possible unresolved transaction race -104/(Websites/Website/_notes,(null))

    Obviously those two are reported by Dreamweaver, but could it be HD problems causing it?
     
  9. OrangeSVTguy macrumors 601

    OrangeSVTguy

    Joined:
    Sep 16, 2007
    Location:
    Northeastern Ohio
    #9
    Do you have the Seagate 1.5TB hard drive? Those have the same problems that you are reporting.

    There's a thread on it, Issue with Seagate 1.5TB?
     
  10. Macpropro80 macrumors 6502

    Joined:
    Jan 31, 2009
    #10
    I think I just pinpointed the problem. I have been having the same problem almost. Are your speakers/head set plugged into a USB hub or directly into the computer. If they are on a hub it is possible they are causing the problem. Plug your speakers directly into your pro. It fix my problem, give it a try.
     
  11. big_malk thread starter macrumors 6502a

    Joined:
    Aug 7, 2005
    Location:
    Scotland
    #11
    I have 2 500GB Samsung drives (one is my boot disk), a Samsung and a WD 250GB drive.

    I have a Griffin Firewave firewire sound card. I have previously considered that this might be to blame, but I was never sure. I'd have to go without my surround sound if I went without it :eek:
     
  12. OrangeSVTguy macrumors 601

    OrangeSVTguy

    Joined:
    Sep 16, 2007
    Location:
    Northeastern Ohio
    #12
    Would it hurt to try and remove that to see if the problem goes away?
     
  13. big_malk thread starter macrumors 6502a

    Joined:
    Aug 7, 2005
    Location:
    Scotland
    #13
    No, I suppose not. I've just gone straight from the line-out to my speakers, and so far there hasn't been an issue, but I guess I won't know if the problems gone away completely for a while.

    What particular problem was it that you have had that's the same? It seems a bit strange that a sound card cause be causing Dreamweaver to hang, I assume your just meaning my iTunes freezes?
     
  14. big_malk thread starter macrumors 6502a

    Joined:
    Aug 7, 2005
    Location:
    Scotland
    #14
    I'm still getting in the console

    kernel unknown SIGSEGV code 0

    and

    /Applications/Adobe Dreamweaver CS4/Adobe Dreamweaver CS4.app/Contents/MacOS/Dreamweaver[343] Allocator race detected: transaction is not verified for -104/2 - Websites/Website/_notes/dwsync.xml

    /Applications/Adobe Dreamweaver CS4/Adobe Dreamweaver CS4.app/Contents/MacOS/Dreamweaver[343] Possible unresolved transaction race -104/(Websites/Website/_notes,(null))

    Does no one know what these might mean? All I can find is people with similar console entries from iTunes and Finder, but no one said what they actually meant?
     
  15. Koppenhoefer macrumors newbie

    Koppenhoefer

    Joined:
    Oct 28, 2009
    Location:
    Lausanne, Switzerland
    #15
    any news on this issue?... what was the final outcome?
     

Share This Page