Native Mail App - Subfolder Notifications not working for Exchange Accounts under iOS 12

bri11oh34d

macrumors newbie
Original poster
Sep 17, 2018
4
0
Anyone else having an issue where you are not receiving subfolder notifications within the native Mail app for exchange accounts since upgrading to ios 12? I have dozens of folders with rules in Exchange that autosend mail to these particular subfolders.

I have the exchange accounts set to Push and the folders all checked under Settings->General->Accounts->Fetch New Data that i want push updates for and notifications for Mail are properly configured in Notification settings but I'm only getting notifications for emails that arrive to the actual inbox. I can see the badges next to the folders within the Mail app so the push updates are working fine, but nothing in notification center for subfolders. Notifications for subfolders has worked as far back as i can remember, for as long as notifications has existed.
 

tjcomerjr

macrumors newbie
Sep 19, 2018
2
0
Same here. Upgraded to iOS 12 yesterday, 9/18, and now new email delivered to exchange subfolders do not result in a notification. Push is enabled for the exchange account and settings>password & accounts>fetch new data the subfolders for which I want to sync under the exchange account are checked. In the native mail app I do see new message counts to the right of the subfolder names but no notification. I removed and re-added the exchange account but no change. Frustrating.

However, I did find a work around. If you go to the mail app and on the account list select Edit at the top right then scroll down and select Add Mailbox. You can then select your exchange account which will show the subfolders, select the subfolder you want to receive notifications for new email and then click done. The subfolder will now be in the mailbox list and should now generate notifications when new email is delivered to that subfolder. Obviously if you have a lot of subfolders this could be a bit cumbersome but works as a band-aid until the issue is corrected.
 

bri11oh34d

macrumors newbie
Original poster
Sep 17, 2018
4
0
As terrible as an alternative as that is, it does work! Makes my native mail app look like a mess with like 100 "mailboxes" now, but at least i get the notifications now! Thank you for the tip!

One additional step i had to take was in Settings->Notifications->Mail, I had to enable notifications for "Favorite Mailboxes." Turning those options on has caused notifications to work as before, albeit with the aesthetic disaster that is now my Mail app.

Thanks again! Lets hope this is a bug that eventually gets fixed and not by design...
 

tjcomerjr

macrumors newbie
Sep 19, 2018
2
0
Here is an interesting bit I discovered that may help you with the clutter. I added one of 12 exchange subfolders in the method I descrbed which added the favorites mailboxes settings to the mail notification settings. After adding one subfolder ALL of my selected folders in fetch new data that have check marks are now getting notifications. It seems that iOS 12 is treating the exchange subfolders as favorite mailboxes, so until you add at least one subfolder to the mailbox list (which adds the favorite mailboxes under mail notification settings) there is no notification for subfolders. There is no way to set notification options for favorite mailboxes until one is added to the mailbox list that I have found. Still a glitch but work around is not as ugly as I first feared for those with lots of subfolders. Let me know if you see the same.
 

bri11oh34d

macrumors newbie
Original poster
Sep 17, 2018
4
0
Yep, noticed the same thing. Once I enabled notifications for "Favorite Mailboxes" i started getting notifications for other folders I had set to Fetch that weren't currently in my list of "Favorites." I just removed all but 1 "Favorite" which has kept the "Favorite Mailboxes" option in place in Notifications and will see what happens.

If this all works, I owe you a digital beer!
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.