Natural scrolling not completely smooth

C64

macrumors 65816
Original poster
Sep 3, 2008
1,235
222
When I scroll with one of the newer trackpads, it doesn't fluently slows down at the send. So, scroll a bit, and at the end it slows down when it's getting to the point where it's supposed to stop. In Snow Leopard it fluently slowed down until it stopped. Now in Lion it stops near the end for a millisecond, and then jumps a tiny bit further to the end.

I have it on multiple machines that are fast enough, so it's not that. Anyone else noticing this? I don't know if this is supposed to work this way, but when you're scrolling all the time it just feels everything is very jittery and suggests that the app can't keep up.
 

SeasideBoy

macrumors newbie
Jul 24, 2011
1
0
Essex, United Kingdom
Jittery Scrolling

This is exactly my experience too. At first I thought it was due to the system indexing the hard drive, but even since this has finished, the scroll is just not as silky smooth as with Snow Leopard.

The problem seems to span every application such as mail and chrome.

I still have my bluetooth magic mouse connected and the effect is the same whether I use the trackpad or the mouse.
 

iammike1

macrumors 6502a
Oct 25, 2007
736
12
O'fallon IL
My personal experience. Scrolling was jagged/jumpy when I upgraded Snow Leopard to Lion. When I did a clean install of Lion the problem was gone.
 

ennerseed

macrumors regular
Jan 3, 2002
142
0
Fixed...

Fixed. I deleted my Mouse Prefs
User/Library(which is invisible now)/Preferences/
com.apple.driver.AppleBluetoothMultitouch.mouse.plist
com.apple.driver.AppleBluetoothMultitouch.mouse.plist.lockfile
com.apple.driver.AppleHIDMouse.plist
All smooth now.

I believe it might be from having smooth scrolling turned off in Snow Leopard and that preference not having a UI for changing in Lion.
 

tblrsa

macrumors regular
Jan 14, 2010
244
2
Oh my god, thanks! I´ve had that same experience too.
 
Last edited:

iammike1

macrumors 6502a
Oct 25, 2007
736
12
O'fallon IL
Fixed. I deleted my Mouse Prefs
User/Library(which is invisible now)/Preferences/
com.apple.driver.AppleBluetoothMultitouch.mouse.plist
com.apple.driver.AppleBluetoothMultitouch.mouse.plist.lockfile
com.apple.driver.AppleHIDMouse.plist
All smooth now.

I believe it might be from having smooth scrolling turned off in Snow Leopard and that preference not having a UI for changing in Lion.
Out of the blue, mine went from smooth to jagged again. I deleted the first two files you listed but didn't find the 3rd one, most likely because I have no Magic Mouse hooked up.

Unfortunately this did not fix the problem for me even after a reboot. :(
 

denture14

macrumors newbie
Jul 31, 2011
7
0
Issues

Yeah, I'm having issues. I'm on a MacBook air and can't find any of those three files you mentioned. However, the scrolling for me is only jittery on certain webpages, mostly busy ones. Even after letting them load completely it still is an annoying setback.

Any suggestions?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.