NatWest banking watch app keeps saying it needs Activating!

Discussion in 'Apple Watch Apps' started by Beards, Jan 25, 2016.

  1. Beards macrumors 6502

    Beards

    Joined:
    Mar 22, 2014
    Location:
    Derbyshire UK
    #1
    Bit of a problem that has suddenly started to happen.
    Until recently if I tapped on the NatWest app on my watch it would duly get my balance and latest transactions, all working well.

    However, what is happening now is when I do the same, instead of the app loading and displaying the above it now simply says ~ "Watch app needs activating, please open the NatWest app on your iPhone".
    If I then go to the app on the iPhone the card has been added and there is no mention of activating for the watch.
    Further, if I go to the wallet app on both the iPhone and watch again the NatWest card is listed and activated.
    It's just the app on the watch that will not accept it is already activated.

    I have telephoned NatWest Apple Pay support, they have deregistered and reregistered the card but on the watch it simply will not stop saying it needs activating.
    They tell me there is nothing further they can help me with.
    Any ideas guys??
     
  2. Armen, Jan 25, 2016
    Last edited: Jan 25, 2016

    Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #2
    my BankofAmerica App wasn't showing my balance on my watch either. I logged in to my account and that fixed it.
     
  3. Beards thread starter macrumors 6502

    Beards

    Joined:
    Mar 22, 2014
    Location:
    Derbyshire UK
    #3
    Yes, as I mention above; I have already tried logging in to the NatWest app on the iPhone but there is nothing to activate. As far as the app is concerned NatWest is already activated. It's just the watch NatWest app that will not accept it is already activated ~ it used to be working just fine for many months on end.
     
  4. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #4
    Tried removing the watch component and reinstall it?
     
  5. Beards thread starter macrumors 6502

    Beards

    Joined:
    Mar 22, 2014
    Location:
    Derbyshire UK
    #5
    Yes thanks.... Done it a number of times including many reboots on both the phone and watch.
     
  6. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #6
    Only other thing I can think of is to reinstall the entire iPhone App and re-add the card. (You probably already tried this I'm assuming)
     
  7. Beards thread starter macrumors 6502

    Beards

    Joined:
    Mar 22, 2014
    Location:
    Derbyshire UK
    #7
    Yes thanks.... and thanks for trying to assist me here. I did this the second time with the NatWest support.
    I'm totally 'fluxed' why this error can't be rectified.
     
  8. testcard macrumors 68020

    testcard

    Joined:
    Apr 13, 2009
    Location:
    Middle England
    #8
    If you haven't tried already, unpairing and repairing might be worth a go.
     
  9. Beards thread starter macrumors 6502

    Beards

    Joined:
    Mar 22, 2014
    Location:
    Derbyshire UK
    #9
    Thanks and I do mean it but yes I've already done that again with NatWest.
    Even tried uninstalling NatWest on the iPhone then unpair followed with repair and reinstall the NatWest app.
    I'm starting to think this is something to do with the iPhones SEID number.
     
  10. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #10
    It sounds like you've tried everything except changing banks. ;)
     
  11. Beards thread starter macrumors 6502

    Beards

    Joined:
    Mar 22, 2014
    Location:
    Derbyshire UK
    #11
    LOL... Yeah. But boy would I love to just find out what caused this issue and get back to checking my balance and transactions without using the iPhone.

    Thanks again for all your input
     
  12. naasrd macrumors 6502

    naasrd

    Joined:
    Apr 30, 2008
    Location:
    Dublin, Ireland
    #12
    For what its worth the Ulster Bank app is the same. Both banks are from the same corporation so I guess the same developer created the flawed app and can't be arsed fixing it.
     
  13. Beards thread starter macrumors 6502

    Beards

    Joined:
    Mar 22, 2014
    Location:
    Derbyshire UK
    #13
    Now that's a good point.... The app was updated on the 19 January and I'm guessing this may well be tied in with the problem.

    It would be fantastic if there are any other NatWest users of the app here to come forward with whether or not this effects them as well.
    If it does I will get back to NatWest (the escalated level of support not just the number we call to query a problem) and feed them as much info as possible.
     
  14. AFEPPL macrumors 68030

    AFEPPL

    Joined:
    Sep 30, 2014
    Location:
    England
    #14
    I had it on my AW this happens if you don't have your mobile details recorded in online banking.
    Just Delete, but the app is very lacking.
     
  15. Beards thread starter macrumors 6502

    Beards

    Joined:
    Mar 22, 2014
    Location:
    Derbyshire UK
    #15
    Thanks... They are definitely recorded.
     
  16. Recognition macrumors 6502

    Recognition

    Joined:
    Jun 27, 2013
    #16
    Just checked my Natwest watch app and having the same issues as you.
    It was working flawlessly for ages but trying it now I get the same message as you.
    Probably a dodgy update as suggested.
     
  17. Beards thread starter macrumors 6502

    Beards

    Joined:
    Mar 22, 2014
    Location:
    Derbyshire UK
    #17
    Try uninstalling then reinstalling. It didn't work for me but in the reviews on this latest version this has been used to fix watch activation issues.
     
  18. TwiceNightly macrumors 6502

    TwiceNightly

    Joined:
    Jun 20, 2008
    #18
    The update for it that came out a couple of days ago fixed it for me
     
  19. Beards thread starter macrumors 6502

    Beards

    Joined:
    Mar 22, 2014
    Location:
    Derbyshire UK
    #19
    Strange..... That's the one that I reckon broke it for me.
     
  20. tarsins macrumors regular

    tarsins

    Joined:
    Sep 15, 2009
    Location:
    Wales
    #20
    I can confirm that the latest update broke the Watch app for me too.
     
  21. Beards thread starter macrumors 6502

    Beards

    Joined:
    Mar 22, 2014
    Location:
    Derbyshire UK
    #21
    Thanks... I'll contact NatWest upper support.
    In the meantime, try uninstalling then reinstalling the app. It fixes the problem for many others.
     
  22. RCSalter macrumors newbie

    Joined:
    May 21, 2015
    #22
    I had this problem with the natwest app the other day too but after I deleted both the phone app and the watch app then reset both devices and reinstalled both apps I then opened the phone app and opened the watch app while keeping the phone app open and then it took me through the activate watch process and was fixed.
     
  23. Seamaster macrumors 6502a

    Seamaster

    Joined:
    Feb 24, 2003
    #23
    Broken for me too. Not that I really ever use the Watch app.
     
  24. tarsins macrumors regular

    tarsins

    Joined:
    Sep 15, 2009
    Location:
    Wales
    #24
    That fixed it for me, thanks.
     
  25. Beards thread starter macrumors 6502

    Beards

    Joined:
    Mar 22, 2014
    Location:
    Derbyshire UK
    #25
    Good to hear.
     

Share This Page