Navigate by Keyboard - randomly does not work

Discussion in 'Mac Basics and Help' started by jasimon9, Jul 30, 2009.

  1. jasimon9 macrumors regular

    Joined:
    Mar 11, 2009
    #1
    When I try to "navigate by keyboard", the function usually does not work.

    I have looked in the Keyboard Preferences and all the boxes are checked for keyboard navigation. For example "Move focus to the menu bar."

    What other magic is needed to make this work?
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    So Fn + Ctrl + F2 for jumping to the Menu Bar and Fn + Ctrl + F3 for accessing the Dock don't work?

    Or what else do you mean by navigating by keyboard?
     
  3. jasimon9 thread starter macrumors regular

    Joined:
    Mar 11, 2009
    #3
    That is correct. They don't work.

    They did work in the past.
     
  4. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #4
    Have you tried repairing permissions and maybe even reset the SMC?

    Have you installed or changed anything lately, that could have contributed to the improper function of the keyboard shortcut?
     
  5. jasimon9 thread starter macrumors regular

    Joined:
    Mar 11, 2009
    #5
    Since the SMC has to do with power functions, that seems unrelated. However I did reset the PRAM/NVRAM recently due to Finder not being able to recognize connected servers, under the direction of an Apple Care technician. Is that what you really meant?

    I had QuickSilver installed for several weeks at least, but I have noticed that it is seemingly non-functional at this time, for unknown reasons. Non-functional in that the hot key to invoke it no longer works, and the icon is missing from the menu bar upper right. The app is still in Applications/Utilities, and it should load when I reboot, but apparently that has not happened. So possibly that's why it is not running.

    Since QS deals with keystrokes, perhaps that is related. Since I have so far not gotten the hang of how to use QS, I don't notice its absence much. I should probably get with it, as I am a "keyboard preferrer."
     
  6. jasimon9 thread starter macrumors regular

    Joined:
    Mar 11, 2009
    #6
    I had already created a thread on this -- but solution there does not work now

    I remembered that I had already posted a thread on this exact subject, titled " Keyboard access to Application Menu". In that thread the "discovery" of the Ctrl-F1 key to enable to disable keyboard access was noted.

    However, that seems to not be working anymore. That is, regardless of the setting in Preferences for Ctrl-F1, and regardless of pressing Ctrl-F1, nothing seems to work for any of these Ctrl keys anymore. Fn-Ctrl-F1 and Fn-Ctrl-F2 don't work either.
     
  7. madog macrumors 65816

    madog

    Joined:
    Nov 25, 2004
    Location:
    Korova Milkbar
    #7
    Have you gone into your Keyboard System Preferences to see if the box is checked for "Use F1, etc. keys as normal function keys"?
     
  8. jasimon9 thread starter macrumors regular

    Joined:
    Mar 11, 2009
    #8
    Yes, that is already checked. But as stated, have tried both with and without Fn.
     

Share This Page