Navigon - need help FAST: enter NYC address a PITA

Discussion in 'iOS Apps' started by araczek, Mar 3, 2011.

  1. araczek macrumors member

    Joined:
    Jun 9, 2010
    #1
    Going to New York city in a couple hours, 2nd time with this freakin Navigon App. I try to "enter an address" . Enter City, New York City. Start trying to put in a street and nothing works. Only thing displayed in lower half of screen are parking, hotels, rental cars, etc.

    Tried: 127 E 23rd St (Gramercy Theater) NO RESULTS FOUND
    (tried 127 first, E or EAST, 23 etc but NOTHING
    Tried: Lexington Ave for street, NO RESULTS FOUND

    Paid GOOD money for this app and it is looking like a waste. What am I missing here?

    Please get in touch ASAP.

    araczek@gmail.com
     
  2. Mjmar macrumors 65816

    Joined:
    May 20, 2008
    #2
    In the top right corner when you're entering the city it has the option to change the state. Make sure your state is NY.
     
  3. mo25 macrumors member

    Joined:
    Feb 1, 2011
    #3
    Lol, I was having the same problem as the OP when I first got the app. Then I realized I was typing an address for a wrong state lol.
     

Share This Page