Necessary to update to 3.0.1?

Discussion in 'Jailbreaks and iOS Hacks' started by impulse462, Aug 2, 2009.

  1. impulse462 Suspended

    impulse462

    Joined:
    Jun 3, 2009
    #1
    Heres the low down,

    I would gladly update to 3.0.1 because I can rejailbreak however the problem is that I had tried the 3.1 beta 1 which upgraded my phones baseband to 5.08.01. (I'm on a 3gs by the way). The reason im asking if its necessary is because when I did downgrade from 3.1 beta 1 to 3.0, I got itunes error, I then went ahead and tried using redsnow to jailbreak. However I did not get any cell data or signal and all the info was described as (null) on the phone. When i used purplerain to jailbreak, however my AT&t signal came back.

    So I have two questions:
    1. Is it an absolute must to upgrade to 3.0.1 because of the SMS exploit?
    2. Does anyone know if purplerain will work to jailbreak 3.0.1?

    Any replies are appreciated
     
  2. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #2
    Yes. Unless you want your iPhone to be hacked. The jailbreaks have been confirmed to work with 3.0.1
     
  3. impulse462 thread starter Suspended

    impulse462

    Joined:
    Jun 3, 2009
    #3
    Both of them? rain/snow?
     
  4. SpaceKitty macrumors 68040

    SpaceKitty

    Joined:
    Nov 9, 2008
    Location:
    Fort Collins Colorado
    #4
    You act like everyone who does not upgrade will be hacked. Very unlikely.
     
  5. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #5
    Actually, no, I don't. I am saying, don't even take the chance and upgrade. Is there a problem with upgrading?
    I would not even take the chance if there was already a fix for it.
     
  6. IBradMac macrumors 68000

    IBradMac

    Joined:
    Jun 27, 2008
    Location:
    Ohio
    #6
    There was a message on Cydia from Saurik that the there will likely be a fix that can be downloaded from Cydia.

    I'll wait for that before I go and re jailbreak.
     
  7. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #7
    Don't even bother upgrading. Do it when 3.1 is out soon.
    It's not a must and highly unlikelly that you'll get attacked by hackers that want to take over controll of your iPhone.
     
  8. Vegastouch macrumors 603

    Vegastouch

    Joined:
    Jul 12, 2008
    Location:
    Las Vegas, NV
    #8

    That is what i want to do. Just dont know how long it will be til 3.1 is released. I cant get into cydia anymore right now. I downloaded a theme and now Cydia wont load anymore. No big deal. I can wait for 3.1 if it will be out soon. Just dont know when that will be.
     
  9. impulse462 thread starter Suspended

    impulse462

    Joined:
    Jun 3, 2009
    #9
    As I said earlier if its completely necessary I will gladly update.

    The only PROBLEM is that I have 5.08.1 and when i restore itunes will give me an error and ill be stuck at the recovery mode screen(not the emergency call screen).

    I would also glady use redsnow to jailbreak but alas when I used it with the 5.08.1 baseband i wouldnt get a carrier signal but with purplerain I did.

    Yes I know im an idiot for upgrading to 3.1 but I cant change the past. I will just wait till 3.1 as I have my ibec and ibss files I guess.
     
  10. darngooddesign macrumors G3

    Joined:
    Jul 4, 2007
    Location:
    Atlanta, GA
    #10
    The SMS exploit may have been fixed in 3.1 beta.
     
  11. impulse462 thread starter Suspended

    impulse462

    Joined:
    Jun 3, 2009
    #11
    Would be nice but I'm back on 3.0 right now :p
     

Share This Page