Need a Mac genius for help with Apple Remote Desktop

Discussion in 'macOS' started by spinne1, Dec 11, 2007.

  1. spinne1 macrumors 6502a

    spinne1

    Joined:
    Mar 12, 2005
    Location:
    Hermitage, TN USA (near Nashville)
    #1
    Hello. I am having considerable trouble trying to set up Apple Remote Desktop between three computers. One, my office Mac. Two, my home Mac. Three, my parent's Mac. I am setting it up so that I can control any of the other computers from any of the three. I have installed ARD admin 3.2 on all three. I have clicked on Apple Desktop Remote in the Sharing folder of the System Preferences of all three. I also clicked the button in preferences which says "allow others to connect to this computer when this program is running" just to expand my chance for success in connnecting. I also set each password in Remote Desktop on each machine to match the password for the admin account of each computer. I am able to connect to my home Mac from either my work Mac or my parent's Mac, but not to the DSL-based computers. The user name and password I use is the shortname and admin password for that particular computer I am trying to connect to.

    Setup:
    Home: cable modem-->router-->hub-->Home Mac (OS X.4.11)(comcast)
    Office: DSL modem/router-->Office Mac (OS X.4.11)(along with two PCs, two office printers, PC backup server)(bellsouth.net)
    Parent's: DSL modem/router-->Parent's Mac (OS X.4.11)(bellsouth.net)

    What I have done:
    Home: went to configure page for router and set up port forwarding for both TCP and UDP for ports 3283 and 5900 for my internal IP of 192.168.0.105. I also recorded my WAN IP, which is in the form 69.x.x.x.

    Office: went to configure page for router and set up port forwarding for both TCP and UDP for ports 3283 and 5900 for my internal IP of 192.168.1.14. I also recorded my WAN IP, which is in the form 70.x.x.x.

    Parent's: Office: went to configure page for router and set up port forwarding for both TCP and UDP for ports 3283 and 5900 for my internal IP of 192.168.1.96. I also recorded my WAN IP, which is in the form 65.x.x.x.

    I was unable to connect to my Office computer from home and so the next day opened my Office router config page and set up IP Passthrough so that the WAN IP would be set to my internal IP for my Office Mac. This too did not work when I got to either of the other computers and I have yet to turn off IP Passthrough (I really did not know what effect this would have on the network in general or my problem in particular but I figured it could not hurt to try.)

    Another thing I did only on my Parent's Mac before I even tried to set this up was to use some mod or hack that a poster put in a web post about opening ports in SSH using 127.0.0.1 and port 5900. I did not change anything else on the other two Macs. I would like to put my Parent's Mac back to default unless it is not the cause of my troubles, in which case I'll let it be.

    The settings in my Parent's DSL modem that I added the SSH stuff are as follows:

    Route-IP Interfaces Subnet Mask Name
    127.0.0.1 255.0.0.0 lo0
    192.168.1.254 255.255.255.0 eth0
    65.x.x.x (WAN IP) 255.255.255.255 mainPPP

    Host Routing Table
    Destination Gateway Interface
    65.x.x.x (WAN IP) 127.0.0.1 lo0
    127.0.0.1 127.0.0.1 lo0
    192.168.1.254 127.0.0.1 lo0
    239.255.255.250 192.168.1.254 eth0

    I don't really understand the lo0 or what exactly this chart is telling me (but I get part of it).

    Does the DSL have anything to do with it not working, or is it something else?

    Anybody have any ideas to help me?
     
  2. mmcxiiad macrumors 6502

    Joined:
    Jul 19, 2002
    #2
    ARD can be tricky sometimes to set up across the internet. While I certianly don't consider myself to be an expert with ARD, here are some things I would do.

    1. Verify that ARD works inside the local subnet. Some routers (like the crappy actiontek that Verizon gave my parents when they signed up for Fios) have problems allowing ARD to work period. I can't get to it even when i am sitting right next to their iMac with my Macbook Pro. Needless to say, that piece of crap is soon going to be removed from this nightmare.

    2. Make sure all of the computers are running the most current version of ARD (either the client or the actual application)

    3. Rather then manually put in the the public IP address, use a service like dyndns. When you add them back into ARD, rather then put in the ip address, put in the hostname. Then regardless of what the ip address becomes later, it all auto updates.

    4. Make sure that when you add them you are NOT doing the force add. If it doesn't add them in after you give it the hostname, username and password something is wrong. Often times it is something set up incorrectly in the router. You may want to make sure that you are running the latest version of the router's firmware. If that still doesn't work, reset the router to factory defaults and try again.

    5. You don't need the router that you are behind to have ports forwarded. Just the one that the computer that you are trying to access.

    Try these things. If it doesn't work, we may need to look closer at how your router is set up. What routers are you using?

    oh and the lo0 is the shortname for your loopback ip address (127.0.0.1)
     

Share This Page