Need advice - can't connect to the internet on my macbook!

Discussion in 'Mac Accessories' started by MusicalJules, Aug 31, 2008.

  1. MusicalJules macrumors newbie

    Joined:
    Aug 31, 2008
    #1
    Hi

    I have a huge problem! I can't connect to the internet using my macbook, however I can connect to it via my iMac and my PC laptop.

    I have full bars on my Airport network but when I try to access a webpage on safari it comes up with the error code that my computer isn't connected to the internet. I then go through network diagnostics, and go through all the stages until it asks me for my wep password, I put this in (which I have double checked with my keychain program) and then it comes up with 'Network Change Detected' - your network configuration has changed. Click OK to proceed to the next step. Click OK and then all the bars disappear and it comes up with an error message that I was unable to join Airport Network. I have a sky router which, as I said previously seems to be working fine as I can access the internet through my other two computers. I can connect to the internet via my Macbook with ethernet but as soon as I take it out I get the same issue. As far as the network status goes, I have a green light for Airport, Airport settings, an amber light for network settings and a red light for ISP, Internet and Server. When looking at my system preferences it tells me that 'Airport has a self assigned IP address and may not be able to connect to the internet'

    I would be really grateful for any support as I am totally stuck.

    Thanks in advance,

    Jules
     
  2. quiz1 macrumors newbie

    Joined:
    Apr 13, 2008
    #2
    I am having the same issue although it just let me on tonight after clicking the airport icon and then doing nothing...?!?

    I started having this problem after not giving my WEP passcode to something called AppleAgent1124 or some sort of number after the "AppleAgent" name. Being new to Mac and generally as suspicious about giving up passwords as my grandparents, I didn't enter it in and now I am generally unable to access the internet due to my network configuration apparently "changing" and it not accepting the WEP passcode I do enter.

    Comcast told me it's likely an Apple problem.

    Can anyone help? Could it be a problem with some sort of update?

    Thanks.
     

Share This Page