Need an answer soon plz MBP 13 Mid 2009 HD Failure?

Discussion in 'MacBook Pro' started by whoknows87, Aug 31, 2012.

  1. whoknows87 macrumors 6502a

    whoknows87

    Joined:
    Aug 8, 2012
    Location:
    S.Florida
    #1
    so I took my laptop to the genius bar today, the issue I am having is after upgrading to ML 3 days my computer decided to never get past the apple logo / spinning wheel page, my HD has 250 GB of, 160 GB free I use it casually nothing heavy duty, RAM is 2 and Processor 2.5Ghz, I ran disk utility i did verify disk , permissions etc It says my HD appears to be OK, I did the whole single user mode /verbose typed in fsck -fy it said HD appears to be OK

    Guy at the Genius Bar said he ran some tests and that the HD is the problem it's failing ? I am confused why would the laptop say the HD appears to be OK and he is telling me it's not, he was quick to offer me the 500GB for 195+installtion fees, I tried to reinstall OS X via wifi using Disk utility but i get an error message saying trying this application later

    I dont expect a HD to fail after 2 years or so
     
  2. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #2
    even if is the hard drive dont pay that, you can do it your self for half maybe even less than half
     
  3. mohsy90 macrumors 65816

    mohsy90

    Joined:
    Feb 4, 2011
    Location:
    New York
    #3
    Yeah, do not get an HD from them. They are ridiculously cheap online and for that price you could get an SDD. Did you do a clean install? If not, I would try wiping the drive clean and trying to reinstall it again. Try creating a bootable ML usb using another computer and boot from that instead. I also have issues with WiFi restore getting stuck. Hopefully you have a backup of your files.
     
  4. whoknows87 thread starter macrumors 6502a

    whoknows87

    Joined:
    Aug 8, 2012
    Location:
    S.Florida
    #4
    it's really frustrating I did not expect the upgrade to ML would cause this mess, I never had any problems with the MB I mean for goodness sake I have 160 GB free out of the 250 GB I understand if I had all types of stuff installed and running with a 2.53GHz Processor and 2 RAM it should run just fine OLDER this is really disappointing I cant seem to erase the disk through disk utility I get error messages like the Disk cant be unmounted etc , what a bummer and Yeah If anything I guess I will just replace it myself order it online any recommendations? I am afraid that it might not be a HD issue after all
     
  5. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #5
    how are you accessing disk utility?
     
  6. whoknows87 thread starter macrumors 6502a

    whoknows87

    Joined:
    Aug 8, 2012
    Location:
    S.Florida
    #6
    the laptop powers I did power option
    I also did the power command R

    what puzzles me is that it when I verify disk/ disk repairs it said my HD appears to be ok....

    also when I hit reinstall OS X from OS X utility it gives me 2 options my HD and Recovery HD I can't click recovery HD is says the disk is locked..

    when trying to reinstall OS X from the CD that came with the laptop it doesnt allow me to start it from my HD it says that one is locked , yellow Exclamation !
     
  7. mohsy90 macrumors 65816

    mohsy90

    Joined:
    Feb 4, 2011
    Location:
    New York
    #7
    There is definitely something is wrong with the HD, you should be able to erase it through disk utility when booting from recovery partition or restore CDs.
     
  8. whoknows87 thread starter macrumors 6502a

    whoknows87

    Joined:
    Aug 8, 2012
    Location:
    S.Florida
    #8
    it says the disk can't be unmounted , all this because I upgraded to ML? this really sucks u figure the laptop should be able to handle the upgrade ....
     

Share This Page