Need an earlier version of Final Cut for G5

Discussion in 'PowerPC Macs' started by WalnutSpice, Mar 10, 2016.

  1. WalnutSpice Suspended

    WalnutSpice

    Joined:
    Jun 21, 2015
    Location:
    Canton, Oh
    #1
    So I'm not having any luck getting my legit Final Cut 4.5 disk to install on my G5. I'm going to try a fresh install of OS X on another partition but if that doesn't work I'd like to find an earlier version of Final Cut that 4.5 but have had no luck finding a legit DVD / CD online anywhere. Any suggestions? I was also thinking an earlier version would probably run smoother on here as well. Really really need that GPU upgrade soon.

    Hm, thinking of it I should try to install the Final Cut 4.5 disk I have on my MacBook under Snow Leopard..
     
  2. tdbmoss, Mar 10, 2016
    Last edited: Mar 12, 2016

    tdbmoss macrumors regular

    tdbmoss

    Joined:
    Dec 4, 2011
    Location:
    UK
    #2
    They should all work on a G5 apart from the latest "X" versions - Final Cut Studio 2 (FCP6) was officially supported on G5s and Final Cut Studio 3 (FCP7) was officially supported only on Intels but was actually shipped as a Universal Binary so can be forced to install on G5s - so your older version should be fine as well. If you have a low-end graphics card like the 5200 the newer versions will probably complain about that, there is a workaround to make it run but probably worth upgrading or it may not run properly.
     

Share This Page