Need an older iTunes

Discussion in 'Mac Apps and Mac App Store' started by davidwes, Feb 10, 2008.

  1. davidwes macrumors regular

    Joined:
    Dec 28, 2004
    #1
    My sister tried to buy a track on itunes and it told her she had to update her itunes to do so. She updated it and then when she went to load it it said her computer was not capable to do so (she has an old iMac g4). Now this was after it installed it. So now she doesn't have any type of itunes that will work on her computer. How can she download something like 7.3?
     
  2. aross99 macrumors 68000

    aross99

    Joined:
    Dec 17, 2006
    Location:
    East Lansing, MI
    #2
    What version of OS X is she running? iTunes 7.6 will run on 10.3.9 on a G4.

    If she is running any version of 10.3, then she can load the software updates to get to 10.3.9 and she should be ok.

    If she is running 10.2.X or 10.1.X, then she should really look at upgrading to one of the newer versions of OS X, so she can get security updates.

    Tiger (10.4) runs really well on the G4 machines.

    I found think link with old versions of iTunes if you really want to go that way:

    http://www.oldapps.com/download_iTunes_mac.php

    Can't vouch for them, but I found it in google...
     

Share This Page