General Need app to disable Autoplay in car when USB connected

Discussion in 'Jailbreaks and iOS Hacks' started by kwyn, Jan 22, 2012.

  1. kwyn macrumors regular

    Joined:
    Jan 9, 2009
    #1
    So, like the title says, I really, really need an app to disable the autoplay of the ipod (music) app as soon as the USB connection is made.

    You see, I like to use rhapsody to listen to music and Grooveshark. Sometimes, I just want to charge the iphone without any music at all. It's annoying to unlock it and press pause. I don't want my ipod to start playing unless I open the app and tell it too.

    Is there any tweak or app to disable the autoplay of the music app?

    thanks so much!!!
     
  2. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #2
    I have never seen a device that turns the music app automatically. Change the settings in the connected device would be my guess since the culprit is not the phone itself unless it wa playing & running music before plugged it...
     
  3. kwyn thread starter macrumors regular

    Joined:
    Jan 9, 2009
    #3
    All my iphones (3G, 4, and 4s) in both my cars and my alarm clock have always started playing on connecting with USB.

    I'm sure you're right that it is the devices that send a command to start playing the ipod app, but I'm hoping that there is a tweak you can do on the iphone to not start playing, because there is no setting on my car stereo to turn it off (stock stereo for Honda Civic LX 2012)
     
  4. bmms8 macrumors 68020

    Joined:
    Dec 19, 2007
    #4
    same here, i do not have anything in iPod on my phone so its not a problem for me
     
  5. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #5
    weird, my Sony & iHome Radios never auto play unless music was already playing before plugging it in with all my iOS devices 4S, 3GS, Nano 6G. What about just having the source be whatever else except the usb port before plugging it? and also try to see if this can help: uncheck in iTunes for the iPhone to open iTunes automatically?
     
  6. mrJnC macrumors regular

    Joined:
    Jul 18, 2007
    #6
    It seems to be a common problem with OEM Honda head units. There is no pause button that works for usb on the head unit. Honda assumes that if you want to pause, you can turn off the head unit. They treat the iPhone connected to the AUX usb as an iPod, and auto play when it's switched to AUX mode. Basically it seems that they intended the head units to be used with iPods and not iPod Touches/iPhones.

    When the phone is connected to the Honda head unit, double tapping the home screen won't bring up the iPod transport controls.

    Where this really becomes a pain is when you're using a navigation app. The music keeps playing and you can't use the controller in the navi app to make it stop... the iPod function overrides it. And if you open the Music (iPod) app, all you see is the accessory connected white splash screen.

    I don't have a real fix for to disable auto play. But there are a couple of workarounds with a jailbroken device.

    The quickest approach is to use SBSettings and get the iPod Widget. This will give you a pause button that you can access from the lock screen. (If you use LockInfo or IntelliscreenX you can have the pause button on the lock screen and hit it without having to invoke the SBSettings drop screen.)

    The other workaround (slower) is to use NoAccSplash which will allow you to open the Music (iPod) app and hit pause there. But it sounds like the OP can already get to the Music app transport controls.
     
  7. kwyn thread starter macrumors regular

    Joined:
    Jan 9, 2009
    #7
    NoAccSplash was the best idea for me. Not perfect, but it'll have to do. Just bring up the pause button and work from there.
     
  8. spamdumpster macrumors 6502a

    Joined:
    Jan 22, 2008
    #8
    I have the same issue with my Acura 2011 MSX (made by Honda, so no surprise).

    Late last week, I sliced open up my iphone charging cable and cut the blue and white data wires, leaving the red and black power/neutral wires in place. I was hoping that this would charge the device without triggering the ipod app to start playing. However, after cutting the data wires, the device wouldn't charge. I remembered reading somewhere that the device won't pull power unless it thinks it's connected, and the way to fix that is to short the two data wires together on the iphone connector end (not the usb end). After I shorted the data wires together, taped everything back up, the device charged fine.

    Since then I haven't had an issue with the ipod auto playing, but it's only been a few days, so I'm not sure if my hack will kill this problem for good. I'll keep you posted.
     
  9. Armeniandave macrumors 6502

    Joined:
    Jun 12, 2010
    Location:
    San Diego
    #9
    My Kenwood DNX6160 does this same thing. I don't put any
    music on it because of it. Always starts at the first song too!
     
  10. kwyn thread starter macrumors regular

    Joined:
    Jan 9, 2009
    #10
    I took all the music off of the ipod app. However, the head unit just said "No music" and then wouldn't allow rhapsody, grooveshark, etc.. to play.

    I had to put 1 song on the ipod app. I just picked something soft, mellow, and instrumental. Then with the No Splash Screen hack, I can double tab "home" and pause it, then open Rhapsody and control it from the phone.

    It's seems like a lot, but it becomes second nature.

    I wish that the car radio would realize people use other music apps.

    Weird thing is that it will show Album covers from groovshark if I hit the back button on the steering wheel. No such luck with Rhapsody though.
     
  11. mrJnC macrumors regular

    Joined:
    Jul 18, 2007
    #11
    I don't know about your other apps, but Pandora can assert itself over the iPod/Music app auto play.

    Before my 4S was JB, the only way I could stop the music was to go to Pandora. Pandora would stop the iPod app in favor of its streaming. Then I would hit pause.

    I suppose a brute force workaround would be to record a long mp3 file of silence and name it "aaaaaaaaa" so that it will be the top hit in the library.
     
  12. jkayc566 macrumors newbie

    Joined:
    Jan 29, 2013
    #12
    Stop the AutoPlay when using USB in the car!

    As if starting the music automatically in the car wasn't enough...

    Start a conversation with your iPhone 5, use your bluetooth device, plug your iPhone into the USB port to charge the phone or use the GPS. Now the music plays through your bluetooth device at the same time your phone conversation is taking place. The person on the other end of the conversation cannot hear the music, you cannot turn off the music, it is very confusing.

    AHHHH!:mad:

    It happened in a rental car, not sure it would happen in every car, but the Buick LaCross had this auto play feature that I could not defeat.

    Can't wait for a fix!
     
  13. lijshaw macrumors newbie

    Joined:
    May 21, 2013
    #13
    Possible solution

    In response to the idea of using a soft mello song as the first song to auto play. It made me realize I could probably easily create a short song of silence and have it autoplay that. I can make a song in garageband or something else and create an MP3 to go in itunes. If I give it the right title then it should show up at the top of the ipod list and always be selected for auto play. Hopefully this will work!
    I have had this problem with both the iphone 2 and now the iphone 5 on a sony aftermarket stereo that I installed. It works pretty great but for that autoplay problem. My Android Samsung Galaxy S never had that auto play problem but wouldnt play via USB from the stereo either. It would just charge on the USB connection.

    Hope that works and is helpful to everyone!
     
  14. Lizzyv823 macrumors newbie

    Joined:
    Jul 5, 2013
    #14
    This happens to me ALL the time. So annoying. Anyone found a fix to this yet? I love Vampire Weekend, but I'm getting really sick of that song!!
     
  15. pollybrowne macrumors member

    pollybrowne

    Joined:
    Nov 4, 2009
    #15
    ^^YES!! I have an MDX...SOOOO annoying, I even went to the trouble of creating a song with no sound named "A" in my library on my phone so if it auto-plays that's first just because it gets on my nerves so much.

    ----------

    Also, does anyone know of a way, when you have the the device connected to the car via USB to disable the 'video out' screen when you try to play a video? I get the audio for the video but now picture, as I do when it's connected to my flat screen.

    It's weird because when you play a video with the USB connected from the Youtube app it works.
     
  16. Kayceelynn79 macrumors newbie

    Joined:
    Nov 15, 2013
    #16
    I have a Mazda protege5 and the same thing happens to me. It's especially embarrassing when I'm actually on the phone and the iMusic is playing while I'm having a conversation!!! So annoying! I hate it. And it takes forever to shut it down.
     
  17. nheilweil macrumors 6502a

    nheilweil

    Joined:
    Jul 10, 2008
    Location:
    Redmond, WA
    #17
    I'm having the exact same issues with my 2013 Civic. Drives me crazy! Maybe with the new jailbreak, someone will write a way to disable the autoplay!
     
  18. dan44 macrumors newbie

    Joined:
    Mar 22, 2010
    Location:
    Switzerland
    #18
    Solved for iTunes Match subscribers

    Hi there, I found a solution as an iTunes Match subscriber. I'm using an iPad mini cellular connected via usb in a Volvo V50 2010.

    1. Delete all your music stored locally on your device (Settings/General/Usage)
    2. Go to Cellular, scroll down and disable the music app to use cellular data
    3. That's it.

    Hope it works for some too.
     
  19. Jonaskazoo macrumors newbie

    Joined:
    Jun 5, 2014
    #19
    Check out the cydia app StopPlayin' from modymi repo... Looks promising. I haven't tested it yet but it claims to have and autoplay toggle among other features specifically for the music app and car issue. Just came out apparently on June 4, 2014.
     
  20. Asator macrumors 6502a

    Asator

    Joined:
    Apr 8, 2011
    Location:
    Australia
    #20
    There's more info here.
     
  21. jpcarro macrumors 6502

    jpcarro

    Joined:
    Mar 13, 2009
    Location:
    On your nine
    #21
    I've been waiting for this. Autoplay is so annoying. Seems to work...waiting for Flipswitch toggle.
     
  22. Old Joseph macrumors newbie

    Old Joseph

    Joined:
    May 17, 2016
    Location:
    Lexington, Kentucky
    #22
    In my case, it drove me crazy that:
    A) Autoplay would launch music every time I plugged my iPhone into my Nissan Sentra's radio/CD player even when I wasn't planning to listen to any songs on my phone. The iPhone music would stop of course when launched (in my case) iHeart Radio but that's not the point.
    B) I tried unchecking all of the songs on my iPhone. Autoplay would then not play any music at plugin but the Apple Map app audio didn't work either. In other words, I couldn't hear the turn-by-turn audio traffic directions without music playing. Even though the map audio directions mutes the music temporarily it was annoying to turn up the volume to hear map directions but then get blasted by music in between.

    After some research, I finally resolved my issue by purchasing and downloading a copy of "Silent Song" from iTunes onto my laptop and then syncing my phone. Silent Song is 10 seconds of silence but it is still an audio file. With the songs on my iPhone unchecked, now when I plug in my phone the Autoplay launches SILENCE. The 10 seconds of Silent Song just loop continuously while the phone is plugged in. If I want to listen to music I launch iHeart Radio. If I want to listen to traffic directions without the distraction of music intervals, I leave iHeart Radio off or swipe it off if it is already playing.
    Sometimes silence is indeed golden.
     
  23. chriscrowlee macrumors 65816

    chriscrowlee

    Joined:
    Aug 10, 2015
    Location:
    San Diego, CA
    #23
    Anything new lately on this front? I normally charge via the AC plug, so it's a non-issue, but recently I've been renting cars and they all auto-play. I don't get why anyone would WANT this. Nobody wants the first song in their alphabetical playlist to start every time they plug their phone into the car.

    Anyone find a way to disable this? It seems like such a no brainer to either have a toggle on the head unit, or a toggle on the phone. It's awful design that Apple starts a song when plugging in.

    Would love to see if anything new is out. I've noticed it when plugging into USB on Toyota, Honda, Hyundai, and Ford vehicles... the common factor is the phone.
     
  24. 1oArthur, Mar 15, 2017
    Last edited: Mar 16, 2017

    1oArthur macrumors newbie

    1oArthur

    Joined:
    Mar 15, 2017
    #24
    I met the same issue before. But I'm happy that the problem solved. You just need to turn off bluetooth on iPhone. Then your iPhone wouldn't connect to the car radio automaticlly. Another solution is change the car audio, switch from bluetooth to FM/AM
     
  25. mikecwest macrumors 6502a

    mikecwest

    Joined:
    Jul 7, 2013
    #25
    I have recently drove several rental cars' Fiat 500X, a Dodge Durango, a Jeep Cherokee, a Kia Optima, Kia Elantra, they all along with my Honda HR-V and Honda Civic, all automatically turn on the music app and play that U2 album that was shoved down our throats.... (thats the only music on my phone.)
     

Share This Page