Need Assistance...

VIPER-X

macrumors newbie
Original poster
Aug 20, 2007
5
0
hey guys, just got my MacBook Pro a few days back.

2.2 Ghz, 120 GB, its been great.

However i have 2 issues.


Sometimes i get electro static shock at my arms where the edges of the macbook pro get contacts with my hand. Just short sharp statics. Is there a fix for this? I got more of these when i connect my Hard Drive. However i jsut got my Sheild Pad for the bottom part of the keyboard, which acts as an insulation too.. =)


Only one other main issue is that i jsut realized COMMAND + S doesnt work when i tried to save stuff... all other commands such as COMMAND + SHIFT + S works just not COMMAND + S.

I installed quicksilver and stuff... any idea how to fix it and enable the COMMAND + S saving again?


Appreciate your replies...
 

ab2650

macrumors 6502a
Jun 21, 2007
714
0
hey guys, just got my MacBook Pro a few days back.

2.2 Ghz, 120 GB, its been great.

However i have 2 issues.


Sometimes i get electro static shock at my arms where the edges of the macbook pro get contacts with my hand. Just short sharp statics. Is there a fix for this? I got more of these when i connect my Hard Drive. However i jsut got my Sheild Pad for the bottom part of the keyboard, which acts as an insulation too.. =)


Only one other main issue is that i jsut realized COMMAND + S doesnt work when i tried to save stuff... all other commands such as COMMAND + SHIFT + S works just not COMMAND + S.

I installed quicksilver and stuff... any idea how to fix it and enable the COMMAND + S saving again?


Appreciate your replies...
As far as the shock goes, are you using the ground/earth cable or the ungrounded 2-prong adapter? I've heard of faulty home wiring causing shocks, almost always having to do with the ground. Investigate when it happens (plugged in, not plugged in, plugged in and grounded).

As far as CMD-S not saving, is this present in all apps? I'd suspect it has to do with quicksilver, but I don't personally use it so I can't comment there.
 

VIPER-X

macrumors newbie
Original poster
Aug 20, 2007
5
0
Thanks for your reply :)

I see... Ill check the static issue.

Regarding the COMMAND + S, it odesnt work for all apps event Text Edit.

I tried closing QuickSilver, it doesnt work either.
Help anyone?
 

VIPER-X

macrumors newbie
Original poster
Aug 20, 2007
5
0
Solved

Thanks..

I used COMMAND + S for text to speech. Heh fixed it.