need Automator Help

Discussion in 'Mac Apps and Mac App Store' started by imacfreak, Oct 28, 2007.

  1. imacfreak macrumors member

    imacfreak

    Joined:
    Aug 19, 2004
    #1
    I am trying to use Automator to extract a bunch of jpgs from an old "iphoto library" folder (where all the photos are tediously buried within several subfolders).. But I just cant get it to work. As the first action, I have "Find Finder Items" and I have the iphoto folder selected, and criteria set to ".jpg". The next action is "Get Folder Contents" and I have "Repeat for each subfolder found" checked. The final action is "Import files to Iphoto" and i have it set to import into a new album. When I try to run it, gives two warnings.. "The action 'Get Folder Contents" was no supplied with required data", and the same for "Import files into iPhoto". I dont know what other data I could supply. Ive attached a picture of my automator window.. Any ideas?
     

    Attached Files:

  2. numlock macrumors 68000

    Joined:
    Mar 13, 2006
    #2
    Two things i notice

    1 You have .jpg and not just plain jpg

    2 I think that "get folder contents" step is useless as the first step already searches every subfolder as well at least if its the same as Tiger (wish that could be turned off.)

    Try it with these modifications

    And if it still dosent dont work and its rather about getting the pictures into iphoto than building a script try a search in the finder and have it search for pictures larger than thumbnails and that are jpg´s in the folder iphoto library
     

Share This Page