Need Flash enabled in latest TenFourFox

Discussion in 'PowerPC Macs' started by WalnutSpice, Dec 13, 2015.

  1. WalnutSpice Suspended

    WalnutSpice

    Joined:
    Jun 21, 2015
    Location:
    Canton, Oh
    #1
    Most of my classes for school are online and the service we use is Plato. Plato was designed in '97, so naturally it is literally 100% flash based, even to this day. I've been using my MacBook but the damn thing runs so loud I got an iBook G4 from my sister to use in school. Super quite, but, safari just doesn't work. Won't load any webpages. But TenFourFox does, but it disables flash and I cannot figure out how to get it back. Can anyone help me with this?

    iBook specs if curious:
    1.33GHz / 1GB RAM / 32MB ATI Radeon 9550 w/ Core Image / 30GB HDD / Late 2005
     
  2. Porridge≈Dude macrumors newbie

    Porridge≈Dude

    Joined:
    Nov 24, 2015
    #2
    Safari does not work at all? Strange. Have you tried other browsers than TenFourFox? It would be much easier to get another browser working than trying to enable Flash in TenFourFox …
     
  3. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #3
    You can't. Not even in about:config. Kaiser disabled plugins permanently a few versions back.
     
  4. WalnutSpice thread starter Suspended

    WalnutSpice

    Joined:
    Jun 21, 2015
    Location:
    Canton, Oh
    #4
    Alright. I just removed Safari via Appzaper and am reinstalling it with Pacifist. I have no idea why it wouldn't work. If not, I guess I'll just go to TFF 17.
     
  5. WalnutSpice thread starter Suspended

    WalnutSpice

    Joined:
    Jun 21, 2015
    Location:
    Canton, Oh
    #5
    No, It just did nothing at all. I've only seen my PowerBook G4 do it when the time / date where wrong. The iBook had no reason for it. I removed Safari via appzaper and am now reinstalling 5.0.3 via Pacifist. Hopefully that works
     
  6. bunnspecial macrumors 603

    bunnspecial

    Joined:
    May 3, 2014
    Location:
    Kentucky
    #6
    Flash is out of the question in TFF.

    Use Tiger/Leopard Webkit if you must use Flash-and be careful.
     
  7. WalnutSpice thread starter Suspended

    WalnutSpice

    Joined:
    Jun 21, 2015
    Location:
    Canton, Oh
    #7
    *Update* So as I use this ibook, It is pretty quick but I'm fairly certain it has a bad install of Leopard. I learned from my last iBook G4 that they can boot from USB drives so I'm just going to reinstall Leopard when I get the time. It works with Plato under TFF 17 and thats all I need. But there are a number of things that simply do not work.
     
  8. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #8
    You can use up to version 24 with plugins. It's versions after that where Kaiser removed the capability.
     
  9. WalnutSpice thread starter Suspended

    WalnutSpice

    Joined:
    Jun 21, 2015
    Location:
    Canton, Oh
    #9
    Alright thanks, I'll go with that version then
     
  10. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #10
    @WalnutSpice Keep in mind that after TenFourFox 17, plugins were disabled by default but could be re-enabled using the about:config control panel in TenFourFox. What I would do is load the latest version of Leopard WebKit along with ClickToPlugin.
     
  11. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #11
    You are correct. However, after version 24 Kaiser disabled this permanently. The about:config setting to turn it on is irrelevant in the higher versions. There's nothing there for it to turn on.
     
  12. WalnutSpice thread starter Suspended

    WalnutSpice

    Joined:
    Jun 21, 2015
    Location:
    Canton, Oh
    #12
    I can't use Webkit. Nothing Safari related at all will work. Safari is 100% broken. I'd need to reinstall OS X for that. I'm currently using TFF 17 with plugins enabled and will update to 23 later
     
  13. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #13
    I would reload OS X then using an Archive & Install option. Try TenFourFox 24 instead of 23.
     
  14. domini99 macrumors member

    domini99

    Joined:
    Sep 1, 2014
    #14
    24 also runs plugins?
    Cool, I'll upgrade my thrusty G5 to 24.

    As for web browsing... That's really what I recommend, an older TFF version that supports plugins.
     
  15. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #15
    Yes. But you need to still go in to about:config, find and change this setting to true: tenfourfox.plugins.enabled

    In regard to your last comment, I find that while I run an optimized profile in T4Fx it's nowhere near any level allowing the use of Flash or video. Generally, if I need that I switch to a webkit browser.

    That's just my take on this. TenFourFox, even optimized, is not anywhere near as light in this regard as other browsers. Unfortunately, other browsers are nowhere near as updated or modern either.
     
  16. domini99 macrumors member

    domini99

    Joined:
    Sep 1, 2014
    #16
    True, but it's fast enough for me.

    When I want to use YouTube I usually use PPC Media Centre, and play the video back using QuickTime.

    Does HD video without a problem.
    I have flash installed, and in-browser (TFF 17) it plays back YouTube very nicely at 480p, but I don't use that very often.
     
  17. Ih8reno macrumors 65816

    Ih8reno

    Joined:
    Aug 10, 2012
  18. Altemose macrumors G3

    Altemose

    Joined:
    Mar 26, 2013
    Location:
    Elkton, Maryland
    #18
    Roccat relies on the underlying WebKit frameworks in OS X. If those files are either corrupted or missing on OP's install, then unfortunately, all WebKit based browsers will suffer.
     

Share This Page