Need For Speed Carbon on Mac Pro

Discussion in 'Mac and PC Games' started by epoche, Oct 10, 2007.

  1. epoche macrumors newbie

    epoche

    Joined:
    Oct 10, 2007
    #1
    Help Help I cannot even get into the game on a Mac Pro 2.66, 5GB RAM. Tried once to use arrows to guide the cars and all I got was a crash after a few seconds.

    Where can I find the Guide to find out how to set up the game. I have tried to use Logitech Freedom 2.4 joystick but can't seem to figure out how to initially configure the game to start. Last time I tried arrow keys would not let me move to the option to quit the game. Have to pull the plug on the Mac Pro to reboot.
     
  2. epoche thread starter macrumors newbie

    epoche

    Joined:
    Oct 10, 2007
    #2
    Need for Speed

    Have suceeded in getting game to play and to work Logitech Freedom 2.4 joystick. Although my game play sucks for now.
     
  3. jasdelta Guest

    #3
    If you can ever get it to run, I'd appreciate knowing what you did. I have a Mac Pro 5G also with Nvidia 7300 GT and I could never get it to run properly. I finally took it back to the Apple Store where I bought it and got a refund on my CC.

    Jim
     

Share This Page