Resolved Need Help Accessing OS X Server Remotely

Discussion in 'Mac OS X Server, Xserve, and Networking' started by adarkenigma, Oct 29, 2013.

  1. adarkenigma, Oct 29, 2013
    Last edited: Oct 29, 2013

    adarkenigma macrumors newbie

    Joined:
    Sep 11, 2010
    #1
    I just did clean install on Mavericks on my mac mini 2012
    and installed OS X Sever 3 app

    I have host name from dyndns when I enter my host name from remote IP or phone
    I get router login page, I want to access web app running on server

    Here are current settings

    Dydns Host is mini$%#@.selfip.net

    Settings from Server App

    Computer Host Name: mini$%#@.selfip.net
    Computer Name: Mini$%#@

    DNS

    Access
    Status: Set your network DNS settings to 192.168.254.70

    Settings

    Forwarding Severs 4
    XX.40.XX.40 —> Primary DNS
    XX.40.XX.41 —> Secondary DNS [got it from router]
    192.168.254.254 —> Router IP address
    192.168.254.70 —> Mac Mini Local address

    Perform Lookups for : only some clients
    The server itself
    Clients on the local network

    Records

    Primary Zone: mini$%#@.selfip.net

    mini$%#@.selfip.net = machine
    mini$%#@.selfip.net = nameserver

    Reverse Zone: 70.254.168.192.im-addr.arpa

    192.168.254.70 = reverse mapping
    mini$%#@.selfip.net = name server

    every time I type mini$%#@.selfip.net from any device it jumps directly to port 80 and goes to router login page
    and if specify port say "mini$%#@.selfip.net:3421" it doesn’t connect.
    I have opened port range in router from 3000 to 4000
    same ports were open in 10.8 and I could access web apps remotely but now no matter what port I change my web apps
    it doesn’t connect.

    what settings do I need to change to make it work?

    can someone help?
     
  2. gobsmacked macrumors member

    Joined:
    Jul 7, 2013
    Location:
    Alberta, Canada
    #2
    You need port forwarding

    It sounds like you need to forward port 80 to your web server.
    You would do this on your router which you don't say what kind it is.
    Assuming it's an Airport this article explains - just replace the Synology Diskstation with your Mac mini.
    On the new version of Airport Utility it's under Network and then Port Settings.
    Hope that helps.
     
  3. adarkenigma thread starter macrumors newbie

    Joined:
    Sep 11, 2010
    #3
    I think I got it I just reset my router to factory default.
    I have UR-344AN4G+ ADSL router which has lame port forwarding

    Oh well it works now, thanks gobsmacked for you help.
     

Share This Page