Need help after issues with macOS 10.12.2 install

Discussion in 'macOS Sierra (10.12)' started by Frankfurt, Dec 15, 2016.

  1. Frankfurt macrumors regular

    Frankfurt

    Joined:
    Dec 4, 2016
    Location:
    USA
    #1
    I need your help please. Here is the chain of events.

    I have 2016 Mbp 15"/2.9/460/1T. This has been working flawlessly. No issues with battery or graphics or anything. I upgraded to 10.12.2 and shortly after re-start noticed that in desk top view open ups would overlay/shine through the background Sierra photo. Boot up time and log in was slowed down. This was only true in my user (admin) account. For a "guest" user it was invisible. I did a PRAM/SMC reset - no impact.

    Called Apple Care. They made me delete Cache and some user preferences to no impact and then suggested to reinstall OS or restore from backup. I restored from time capsule the 10.12.1 back up just before the update. When done, I was back on 10.12.1 but the obscure user profile issue was still there. Also, mail app was corrupted and could not be opened.

    Next I did a wipe and reinstall to start over fresh. However, I was unable to set up my mail accounts (I was told I was already signed in - I never ever had such an issue). I did another restore from time capsule (this time from a few days earlier). Same issues: profile still with distortion above, mail app corrupted (I have no idea why this would be).

    Then I upgraded to 10.12.2 just to see what happens: mail recovered and can be opened again (some changes were made to mail apparently in 12.2).

    However, the original issues still persists: when logged in as me (admin), desktop background will be overlaid on the edges of the screen with open ups and log in is somewhat buggy.

    I am at the end of my wisdom.

    Any suggestions?
     
  2. mossy macrumors regular

    mossy

    Joined:
    Sep 11, 2013
    Location:
    Ireland
    #2
    Restart -> boot into recovery mode cmd+R -> run the disk utility -> then (still in recovery) reinstall the OS.

    It might sort out some of the gremlins.

    Can you post a screenshot of your issue?
     
  3. FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #3
    If it's not happening in Guest, it might be FileVault related. Try disabling FileVault?
     
  4. Frankfurt thread starter macrumors regular

    Frankfurt

    Joined:
    Dec 4, 2016
    Location:
    USA
    #4
    Thank you, guys. FileVault is disabled. I did wipe it again and reinstall. This reinstall came already as 10.12.2. The graphic glitch continued. After talking with Apple Care I decided to return the unit tomorrow (I am still in the holiday return period). Apple Care could not identify the cause (2nd level). What is strange is that the issue coincided with the 12.2 upgrade. Maybe a faulty GPU after all - though running D showed no issues.
    I wait a few months before getting a replacement. Let Apple work things out. Going back to my Late 2008 5.1 is a drama though after handling this fine machine for three weeks.
    I am a big fan of the new Macbook Pro with TB. I will get another i due time.
     

Share This Page