Need Help: Can't install updated version of apps

Discussion in 'iPhone Tips, Help and Troubleshooting' started by cheapa55, Sep 9, 2008.

  1. cheapa55 macrumors 6502a

    Joined:
    Oct 29, 2007
    #1
    I downloaded the updated apps in itunes and when it tries to install, I get this (see pic). Any ideas? I tried starting from scratch (deleted all apps, install ALL from itunes, but when a new update shows up, I still see the same error).

    Any help is greatly appreciated (tried searching, can't find any info)
     

    Attached Files:

  2. soberbrain macrumors 65816

    soberbrain

    Joined:
    May 9, 2008
    #2
    App updates in iTunes seem to be buggy. Not sure if iTunes 8 fixed that or if iPhone 2.1 will fix it.

    I've been updating my apps through the iPhone, not iTunes, with no problems.
     
  3. kayno macrumors regular

    kayno

    Joined:
    Aug 19, 2008
    Location:
    Phelps Land
    #3
    Just reinstall the apps through your phone.. it will give you the updated version.. sometimes the updates might not show up in the update tab.. just got to the actual app in whatever category it resides in or search for it and install it from there.. that always works..
     
  4. cheapa55 thread starter macrumors 6502a

    Joined:
    Oct 29, 2007
    #4
    Thanks, but the problem is not being able to get the latest version, but getting it updated. I dont' want to always have to re-enter my usernames and passwords for some of the apps. I am using itunes 8. I hope the 2.1 update for the phone will fix this.

    Anyone else having this problem?
     
  5. wellgroomednerd macrumors newbie

    Joined:
    Jul 12, 2008
    #5
    I am also having a problem. I'm up at 7 app errors.
     
  6. rogersmj macrumors 68020

    rogersmj

    Joined:
    Sep 10, 2006
    Location:
    Indianapolis, IN
    #6
    I just posted about this last week, and apparently others have too. No one has an answer other than removing the apps from the phone and then syncing again. It's a pain. 2.1 had better fix it.
     
  7. cheapa55 thread starter macrumors 6502a

    Joined:
    Oct 29, 2007
    #7
    Thanks mrogers. This sucks but I have a feeling everything will change this friday. Thanks.
     
  8. cheapa55 thread starter macrumors 6502a

    Joined:
    Oct 29, 2007
    #8
    Updated to 2.1, still can't update my apps!!! Decided to delete and reinstall again. We'll see if the next app update causes the same problem.
     
  9. bluenoise macrumors 6502a

    Joined:
    Jul 16, 2008
    #9
    Same here. This and the fact I can't get any service if 3G is enabled makes me think another nuke&pave is in my future (or a trip to the Apple store).:mad:
     
  10. cheapa55 thread starter macrumors 6502a

    Joined:
    Oct 29, 2007
    #10
    Sucks for us, but I'm glad I'm not the only one. Hopefully enough people still have this issue that it will be resolved by Apple. Let's just hope it doesn't take too long, it's really annoying.
     

Share This Page