Resolved Need help changing Trash permissions

Discussion in 'macOS' started by Diogones, Oct 1, 2011.

  1. Diogones, Oct 1, 2011
    Last edited: Oct 1, 2011

    Diogones macrumors regular

    Diogones

    Joined:
    Dec 23, 2009
    #1
    I was attempting to change the display options on my computer, and deleted the com.apple.WindowServer.plist file, rendering my Mac unbootable. Fortunately, I did not empty the Trash, so it is still in there. I've tried to restore the file to its proper directory, but since I can't log into the Mac normally, I wasn't sure what I should do.

    I tried moving or copying it via a Linux live CD, but it came up with an error message stating that, "The directory is read only." I also booted my Mac into Single User Mode and tried moving it via the command line, but again, it wouldn't allow me to move or copy the file, stating that it was read only. Even when I tried to change the permissions with sudo and chmod, I get the "Unable to change permissions, directory is read only mode." If I can't change the permissions to move or copy the file, how am I to restore it?

    I did consult this very helpful Macrumors thread: http://forums.macrumors.com/showthread.php?t=616959 but his solution was to use another Mac, put the afflicted Mac in Target Disk Mode, and move the file that way. But I don't have another Mac to use Target Disk Mode. Besides, if permissions are not an issue using another Mac via Disk Mode, why are they so in the Linux CD and in Single User Mode?
     
  2. Sc00tr macrumors regular

    Joined:
    May 28, 2011
    #2
    try single disk mode and log in as root then make the copy.
     
  3. Diogones thread starter macrumors regular

    Diogones

    Joined:
    Dec 23, 2009
    #3
    Thanks for your suggestion, sc00tr! Your idea did the trick! I was able to move the file to its correct directory once I had properly logged in as root! I didn't realize that I could use the "su -" command to go to root, but once I found out, I was back in business! A big thumbs up for your help! :cool:
     

Share This Page