Need Help! Ethernet Bonding Issues

Discussion in 'Mac OS X Server, Xserve, and Networking' started by ntdogg511, Feb 22, 2010.

  1. ntdogg511 macrumors newbie

    Mar 4, 2008
    So here is the brunt of it:

    Two Quad Core xServes, identical in every way. Two Foundry switches identical in every way with LACP support.

    I ran a network cable from each ethernet port, one to one switch, one to the other for HA. Same for the other xserve.

    I turn on ethernet bonding on one, working fine everything connects up.

    I turn it on on the other one, nothing connects, gives "wrong group" error under advanced.

    What is going on here, if I flip flop them, then the other one works. But only one will work at a time. How is a software ethernet bond messing with the other server??????

    I tried the dinky stuff like MAC address being the same, bad cable etc. The switch is configured correctly, I have many a dell server running the exact same way as this.

    I know I have to be overlooking something stupid I'm guessing but this is driving me crazy, any help would be appreciated.
  2. belvdr macrumors 603

    Aug 15, 2005
    No longer logging into MR
    Is this what you're doing:

    Server A -> One port to switch X and one to switch Y
    Server B -> One port to switch X and one to switch Y

    If so, the switches need to support bonding across the physical devices. In the Cisco world, you need something like the VSS supervisors to support that.

    If not, you need to make sure they are in different port groups. If all you're trying to do is HA on the NICs (i.e. do not really need the bonded ports for extra bandwidth), I'd see if you can configure the Xserve to use one IP and dedicate one NIC as active and the other as backup. Then, you can remove the port channelling altogether.

Share This Page